CVE-2014-3661 Jenkins Denial of Service vulnerability

Medium 5.0 Published Updated

Remote attackers can cause a denial of service in Jenkins by consuming threads via CLI handshake vectors, requiring an upgrade to mitigate.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-3661?

CVE-2014-3661 is a medium-severity denial of service vulnerability in Jenkins Jenkins, published on 16 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Jenkins before 1.583 and LTS before 1.565.3 allows remote attackers to cause a denial of service (thread consumption) via vectors related to a CLI handshake.

Weakness: CWE-399

Which versions are affected by CVE-2014-3661?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.565.3
org.jenkins-ci.main:jenkins-core MavenAll versions1.565.3
org.jenkins-ci.main:jenkins-core MavenFrom 1.5661.583
org.jenkins-ci.main:jenkins-core MavenFrom 1.5661.583

Products include Jenkins Jenkins, Redhat Openshift.

How do I fix CVE-2014-3661?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.565.3 or 1.583.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2014-3661 being exploited?

There is no known exploitation of CVE-2014-3661 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-r5m2-g5gc-q43r.

Is CVE-2014-3661 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free