CVE-2014-3662 Jenkins Exposure of Sensitive Information to an Unauthorized Actor vulnerability
Remote attackers can enumerate valid user names on Jenkins servers by analyzing login attempt responses, exposing potential targets for further attacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-3662?
CVE-2014-3662 is a medium-severity vulnerability in Jenkins Jenkins, published on 16 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Jenkins before 1.583 and LTS before 1.565.3 allows remote attackers to enumerate user names via vectors related to login attempts.
Weakness: CWE-200
Which versions are affected by CVE-2014-3662?
4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.jenkins-ci.main:jenkins-core Maven | All versions | 1.565.3 |
org.jenkins-ci.main:jenkins-core Maven | All versions | 1.565.3 |
org.jenkins-ci.main:jenkins-core Maven | From 1.566 | 1.583 |
org.jenkins-ci.main:jenkins-core Maven | From 1.566 | 1.583 |
Products include Jenkins Jenkins, Redhat Openshift.
How do I fix CVE-2014-3662?
Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.565.3 or 1.583.
Is CVE-2014-3662 being exploited?
There is no known exploitation of CVE-2014-3662 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Jenkins
- CVE-2024-23897 Jenkins Command Line Interface (CLI) Path Traversal
- CVE-2018-1000861 Jenkins Stapler Web Framework Deserialization of Untrusted Data
- CVE-2017-1000353 Jenkins Remote Code Execution
- CVE-2015-5317 Jenkins User Interface (UI) Information Disclosure
- CVE-2021-21690 Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins
Sources
Also known as GHSA-fxqr-px2m-fvc2.