# CVE-2014-3662: Jenkins Exposure of Sensitive Information to an Unauthorized Actor vulnerability

> Remote attackers can enumerate valid user names on Jenkins servers by analyzing login attempt responses, exposing potential targets for further attacks.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-fxqr-px2m-fvc2

## What is CVE-2014-3662?

CVE-2014-3662 is a medium-severity vulnerability in Jenkins Jenkins, published on 16 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins before 1.583 and LTS before 1.565.3 allows remote attackers to enumerate user names via vectors related to login attempts.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2014-3662?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 1.565.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 1.565.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 1.566 | 1.583 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 1.566 | 1.583 |

Products: Jenkins Jenkins, Redhat Openshift.

## How do I fix CVE-2014-3662?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.565.3 or 1.583.

## Is CVE-2014-3662 being exploited?

There is no known exploitation of CVE-2014-3662 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3662 and fix it if it is affected.

What it is: CVE-2014-3662 is a medium-severity vulnerability in Jenkins Jenkins, published on 16 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3662 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.565.3
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.565.3
- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.566; fixed in 1.583
- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.566; fixed in 1.583

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3662/ (Markdown: https://insights.sbomify.com/CVE-2014-3662/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3662
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3662
- OSV: https://osv.dev/vulnerability/CVE-2014-3662

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3662/
Summaries are generated and may contain mistakes; the official description above is the record.
