CVE-2014-3663 Jenkins allows remote authenticated users to bypass intended restrictions and create or destroy arbitrary jobs

Medium 6.0 Published Updated

Authenticated users with Job/CONFIGURE permission can bypass restrictions to create or destroy arbitrary jobs in Jenkins.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-3663?

CVE-2014-3663 is a medium-severity missing authorization vulnerability in Jenkins Jenkins, published on 16 Oct 2014. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Jenkins before 1.583 and LTS before 1.565.3 allows remote authenticated users with the Job/CONFIGURE permission to bypass intended restrictions and create or destroy arbitrary jobs via unspecified vectors.

Weakness: CWE-264

Which versions are affected by CVE-2014-3663?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.565.3
org.jenkins-ci.main:jenkins-core MavenAll versions1.565.3
org.jenkins-ci.main:jenkins-core MavenFrom 1.5661.583
org.jenkins-ci.main:jenkins-core MavenFrom 1.5661.583

Products include Jenkins Jenkins, Redhat Openshift.

How do I fix CVE-2014-3663?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.565.3 or 1.583.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2014-3663 being exploited?

There is no known exploitation of CVE-2014-3663 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-64mc-2m9p-23c8.

Is CVE-2014-3663 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free