CVE-2014-3666 Jenkins allows for Code Execution via Crafted Packet to the CLI

High 7.5 Published Updated

Remote attackers can execute arbitrary code on Jenkins servers via the CLI channel without authentication.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-3666?

CVE-2014-3666 is a high-severity code injection vulnerability in Jenkins Jenkins, published on 16 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Jenkins before 1.583 and LTS before 1.565.3 allows remote attackers to execute arbitrary code via a crafted packet to the CLI channel.

Weakness: CWE-94

Which versions are affected by CVE-2014-3666?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.565.3
org.jenkins-ci.main:jenkins-core MavenAll versions1.565.3
org.jenkins-ci.main:jenkins-core MavenFrom 1.5661.583
org.jenkins-ci.main:jenkins-core MavenFrom 1.5661.583

Products include Jenkins Jenkins, Redhat Openshift.

How do I fix CVE-2014-3666?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.565.3 or 1.583.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2014-3666 being exploited?

There is no known exploitation of CVE-2014-3666 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-fvfh-8mj3-23xj.

Is CVE-2014-3666 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free