CVE-2014-3667 Jenkins allows Remote Users to Obtain Sensitive Information from a Plugin Code

Medium 4.0 Published Updated

Authenticated users with read permissions can download plugin code to obtain sensitive information.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-3667?

CVE-2014-3667 is a medium-severity vulnerability in Jenkins Jenkins, published on 16 Oct 2014. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Jenkins before 1.583 and LTS before 1.565.3 does not properly prevent downloading of plugins, which allows remote authenticated users with the Overall/READ permission to obtain sensitive information by reading the plugin code.

Weakness: CWE-200

Which versions are affected by CVE-2014-3667?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.565.3
org.jenkins-ci.main:jenkins-core MavenAll versions1.565.3
org.jenkins-ci.main:jenkins-core MavenFrom 1.5661.583
org.jenkins-ci.main:jenkins-core MavenFrom 1.5661.583

Products include Jenkins Jenkins, Redhat Openshift.

How do I fix CVE-2014-3667?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.565.3 or 1.583.

Is CVE-2014-3667 being exploited?

There is no known exploitation of CVE-2014-3667 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-5xm3-48v5-6h7v.

Is CVE-2014-3667 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free