{"answers":{"affected":"2 open source packages ship an affected version, including org.jvnet.hudson.plugins:monitoring. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-3679 in the wild and no public exploit code.","fix":"Upgrade org.jvnet.hudson.plugins:monitoring to 1.53.0 or later.","what":"CVE-2014-3679 is a medium-severity vulnerability in n/a, published on 16 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-3679 and fix it if it is affected.\n\nWhat it is: CVE-2014-3679 is a medium-severity vulnerability in n/a, published on 16 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-3679 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jvnet.hudson.plugins:monitoring (Maven): affected all versions; fixed in 1.53.0\n- org.jvnet.hudson.plugins:monitoring (Maven): affected all versions; fixed in 1.53.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3679/ (Markdown: https://insights.sbomify.com/CVE-2014-3679/index.md)","id":"CVE-2014-3679","markdown":"https://insights.sbomify.com/CVE-2014-3679/index.md","name":"CVE-2014-3679","record":{"aliases":["GHSA-qwc3-p5pc-q93h"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Monitoring plugin","requires_auth":"none","summary":"Remote attackers can obtain sensitive information by accessing unspecified pages in the Jenkins Monitoring plugin.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"monitoring_plugin","vendor":"jenkins-ci"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:N/A:N","version":"2.0"},"cwes":[],"description":"The Monitoring plugin before 1.53.0 for Jenkins allows remote attackers to obtain sensitive information by accessing unspecified pages.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Monitoring Plugin Reveals Sensitive Information via Unspecified Pages","id":"CVE-2014-3679","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2014"},"n_packages":2,"n_references":2,"next":{"headline":"Jenkins Exposure of Sensitive Information to an Unauthorized Actor vulnerability","id":"CVE-2014-3680"},"packages":[{"ecosystem":"Maven","fixed":["1.53.0"],"introduced":["0"],"last_affected":[],"package":"org.jvnet.hudson.plugins:monitoring","purl":null,"source":"GHSA-qwc3-p5pc-q93h"},{"ecosystem":"Maven","fixed":["1.53.0"],"introduced":["0"],"last_affected":[],"package":"org.jvnet.hudson.plugins:monitoring","purl":"pkg:maven/org.jvnet.hudson.plugins/monitoring","source":"GHSA-qwc3-p5pc-q93h"}],"prev":{"headline":"Jenkins Monitoring Plugin allows Cross-Site Scripting (XSS)","id":"CVE-2014-3678"},"products":["n/a"],"published":"2014-10-16","related":[{"cvss_score":4.3,"headline":"Jenkins Monitoring Plugin allows Cross-Site Scripting (XSS)","id":"CVE-2014-3678","kev_date_added":null,"published":"2014-10-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can obtain sensitive information by accessing unspecified pages in the Jenkins Monitoring plugin.","url":"https://insights.sbomify.com/CVE-2014-3679/"}