CVE-2014-3680 Jenkins Exposure of Sensitive Information to an Unauthorized Actor vulnerability

Medium 4.0 Published Updated

Authenticated users with Job/READ permission can view default password values in parameterized jobs, exposing sensitive credentials.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-3680?

CVE-2014-3680 is a medium-severity vulnerability in Jenkins Jenkins, published on 16 Oct 2014. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Jenkins before 1.583 and LTS before 1.565.3 allows remote authenticated users with the Job/READ permission to obtain the default value for the password field of a parameterized job by reading the DOM.

Weakness: CWE-200

Which versions are affected by CVE-2014-3680?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.565.3
org.jenkins-ci.main:jenkins-core MavenAll versions1.565.3
org.jenkins-ci.main:jenkins-core MavenFrom 1.5661.583
org.jenkins-ci.main:jenkins-core MavenFrom 1.5661.583

Products include Jenkins Jenkins, Redhat Openshift.

How do I fix CVE-2014-3680?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.565.3 or 1.583.

Is CVE-2014-3680 being exploited?

There is no known exploitation of CVE-2014-3680 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-8x8p-mfwv-9fjw.

Is CVE-2014-3680 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free