CVE-2014-3681 Jenkins Cross-site Scripting vulnerability

Medium 4.3 Published Updated

Remote attackers can inject arbitrary web script or HTML into Jenkins, potentially compromising user sessions or executing malicious code.

Exploited in the wild
Not known
Login needed
Not stated
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2014-3681?

CVE-2014-3681 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 15 Oct 2014. It can be exploited over the network, and only if a user opens a file or follows a link.

Official description

Cross-site scripting (XSS) vulnerability in Jenkins before 1.583 and LTS before 1.565.3 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Weakness: CWE-79

Which versions are affected by CVE-2014-3681?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.565.3
org.jenkins-ci.main:jenkins-core MavenAll versions1.565.3
org.jenkins-ci.main:jenkins-core MavenFrom 1.5661.583
org.jenkins-ci.main:jenkins-core MavenFrom 1.5661.583

Products include Jenkins Jenkins, Redhat Openshift.

How do I fix CVE-2014-3681?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.565.3 or 1.583.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2014-3681 being exploited?

There is no known exploitation of CVE-2014-3681 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-cwh9-f8m6-6r63.

Is CVE-2014-3681 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free