{"answers":{"affected":"It affects 4 products.","exploited":"There is no known exploitation of CVE-2014-3686 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2014-3686 is a medium-severity command injection vulnerability in Canonical Ubuntu Linux, published on 16 Oct 2014. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-3686 and fix it if it is affected.\n\nWhat it is: CVE-2014-3686 is a medium-severity command injection vulnerability in Canonical Ubuntu Linux, published on 16 Oct 2014. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-3686 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3686/ (Markdown: https://insights.sbomify.com/CVE-2014-3686/index.md)","id":"CVE-2014-3686","markdown":"https://insights.sbomify.com/CVE-2014-3686/index.md","name":"CVE-2014-3686","record":{"aliases":["DEBIAN-CVE-2014-3686","DLA-147-1","DSA-3052-1","GHSA-mvf7-8vcg-m9vv","MGASA-2014-0429","RHSA-2014:1956","UBUNTU-CVE-2014-3686","USN-2383-1"],"analysis":{"component_type":"operating_system","fix_type":"patch","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"WPA supplicant","requires_auth":"none","summary":"Remote attackers can execute arbitrary commands on systems running wpa_supplicant or hostapd with specific action script configurations via crafted frames.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"hostapd","vendor":"w1.fi"},{"product":"wpa_supplicant","vendor":"w1.fi"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"wpa_supplicant and hostapd 0.7.2 through 2.2, when running with certain configurations and using wpa_cli or hostapd_cli with action scripts, allows remote attackers to execute arbitrary commands via a crafted frame.","ecosystems":["Red Hat:enterprise_linux:7::client","Red Hat:enterprise_linux:7::computenode","Red Hat:enterprise_linux:7::server","Red Hat:enterprise_linux:7::workstation"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command injection in n/a","id":"CVE-2014-3686","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux"],"type":"command_injection","year":"2014"},"n_packages":8,"n_references":16,"next":{"headline":"Denial of service in n/a","id":"CVE-2014-3687"},"packages":[{"ecosystem":"Red Hat:enterprise_linux:7::client","fixed":["1:2.0-13.el7_0"],"introduced":["0"],"last_affected":[],"package":"wpa_supplicant","purl":"pkg:rpm/redhat/wpa_supplicant","source":"RHSA-2014:1956"},{"ecosystem":"Red Hat:enterprise_linux:7::client","fixed":["1:2.0-13.el7_0"],"introduced":["0"],"last_affected":[],"package":"wpa_supplicant-debuginfo","purl":"pkg:rpm/redhat/wpa_supplicant-debuginfo","source":"RHSA-2014:1956"},{"ecosystem":"Red Hat:enterprise_linux:7::computenode","fixed":["1:2.0-13.el7_0"],"introduced":["0"],"last_affected":[],"package":"wpa_supplicant","purl":"pkg:rpm/redhat/wpa_supplicant","source":"RHSA-2014:1956"},{"ecosystem":"Red Hat:enterprise_linux:7::computenode","fixed":["1:2.0-13.el7_0"],"introduced":["0"],"last_affected":[],"package":"wpa_supplicant-debuginfo","purl":"pkg:rpm/redhat/wpa_supplicant-debuginfo","source":"RHSA-2014:1956"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["1:2.0-13.el7_0"],"introduced":["0"],"last_affected":[],"package":"wpa_supplicant","purl":"pkg:rpm/redhat/wpa_supplicant","source":"RHSA-2014:1956"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["1:2.0-13.el7_0"],"introduced":["0"],"last_affected":[],"package":"wpa_supplicant-debuginfo","purl":"pkg:rpm/redhat/wpa_supplicant-debuginfo","source":"RHSA-2014:1956"},{"ecosystem":"Red Hat:enterprise_linux:7::workstation","fixed":["1:2.0-13.el7_0"],"introduced":["0"],"last_affected":[],"package":"wpa_supplicant","purl":"pkg:rpm/redhat/wpa_supplicant","source":"RHSA-2014:1956"},{"ecosystem":"Red Hat:enterprise_linux:7::workstation","fixed":["1:2.0-13.el7_0"],"introduced":["0"],"last_affected":[],"package":"wpa_supplicant-debuginfo","purl":"pkg:rpm/redhat/wpa_supplicant-debuginfo","source":"RHSA-2014:1956"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2014-3685"},"products":["n/a"],"published":"2014-10-16","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary commands on systems running wpa_supplicant or hostapd with specific action script configurations via crafted frames.","url":"https://insights.sbomify.com/CVE-2014-3686/"}