# CVE-2014-3709: JBoss Keycloak CSRF Vulnerability

> Remote attackers can perform cross-site request forgery attacks against Keycloak social login callbacks due to missing CSRF protection.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Oct 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-xr6q-qqx7-553g

## What is CVE-2014-3709?

CVE-2014-3709 is a high-severity vulnerability in n/a, published on 18 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The org.keycloak.services.resources.SocialResource.callback method in JBoss KeyCloak before 1.0.3.Final allows remote attackers to conduct cross-site request forgery (CSRF) attacks by leveraging lack of CSRF protection.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2014-3709?

2 open source packages ship an affected version, including org.keycloak:keycloak-services. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions | 1.0.3.Final |
| `org.keycloak:keycloak-services` | Maven | All versions | 1.0.3.Final |

Products: Keycloak Keycloak.

## How do I fix CVE-2014-3709?

Upgrade org.keycloak:keycloak-services to 1.0.3.Final or later.

## Is CVE-2014-3709 being exploited?

There is no known exploitation of CVE-2014-3709 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-12161](https://insights.sbomify.com/CVE-2017-12161/): Moderate severity vulnerability that affects org.keycloak:keycloak-core (high 8.8)
- [CVE-2014-3651](https://insights.sbomify.com/CVE-2014-3651/): Keycloak vulnerable to uncontrolled resource consumption (high 7.5)
- [CVE-2017-12159](https://insights.sbomify.com/CVE-2017-12159/): Keycloak CSRF Vulnerability (high 7.5)
- [CVE-2017-12158](https://insights.sbomify.com/CVE-2017-12158/): Keycloak Reflected XSS (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3709 and fix it if it is affected.

What it is: CVE-2014-3709 is a high-severity vulnerability in n/a, published on 18 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-3709 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 1.0.3.Final
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 1.0.3.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3709/ (Markdown: https://insights.sbomify.com/CVE-2014-3709/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3709
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3709
- OSV: https://osv.dev/vulnerability/CVE-2014-3709

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3709/
Summaries are generated and may contain mistakes; the official description above is the record.
