CVE-2014-3730 Django Allows Open Redirects
Remote attackers can redirect users to malicious sites via malformed URLs due to improper validation in Django's URL safety check.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2014-3730?
CVE-2014-3730 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 16 May 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The django.util.http.is_safe_url function in Django 1.4 before 1.4.13, 1.5 before 1.5.8, 1.6 before 1.6.5, and 1.7 before 1.7b4 does not properly validate URLs, which allows remote attackers to conduct open redirect attacks via a malformed URL, as demonstrated by "http:\\\djangoproject.com."
Weakness: CWE-20
Which versions are affected by CVE-2014-3730?
9 open source packages ship an affected version, including django and Django. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | From 1.4 | 1.4.13, 1.5.8, 1.6.5, 1.7b4 |
django PyPI | From 1.4 | 1.4.13 |
django PyPI | From 1.5 | 1.5.8 |
django PyPI | From 1.6 | 1.6.5 |
django PyPI | From 1.7a1 | 1.7b4 |
Django PyPI | From 1.4 | 1.4.13 |
3 more packages
Django PyPI | From 1.5 | 1.5.8 |
Django PyPI | From 1.6 | 1.6.5 |
Django PyPI | From 1.7a1 | 1.7b4 |
Products include Canonical Ubuntu Linux, Debian Debian Linux, Djangoproject Django, Opensuse Opensuse.
How do I fix CVE-2014-3730?
Upgrade django to a fixed version for your release line: 1.4.13, 1.5.8, 1.6.5 or 1.7b4.
Is CVE-2014-3730 being exploited?
There is no known exploitation of CVE-2014-3730 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2014-3730, GHSA-vq3h-3q7v-9prw, PYSEC-2014-20.