# CVE-2014-3730: Django Allows Open Redirects

> Remote attackers can redirect users to malicious sites via malformed URLs due to improper validation in Django's URL safety check.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 May 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-3730, GHSA-vq3h-3q7v-9prw, PYSEC-2014-20

## What is CVE-2014-3730?

CVE-2014-3730 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 16 May 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The django.util.http.is_safe_url function in Django 1.4 before 1.4.13, 1.5 before 1.5.8, 1.6 before 1.6.5, and 1.7 before 1.7b4 does not properly validate URLs, which allows remote attackers to conduct open redirect attacks via a malformed URL, as demonstrated by "http:\\\djangoproject.com."

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2014-3730?

9 open source packages ship an affected version, including django and Django. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | From 1.4 | 1.4.13, 1.5.8, 1.6.5, 1.7b4 |
| `django` | PyPI | From 1.4 | 1.4.13 |
| `django` | PyPI | From 1.5 | 1.5.8 |
| `django` | PyPI | From 1.6 | 1.6.5 |
| `django` | PyPI | From 1.7a1 | 1.7b4 |
| `Django` | PyPI | From 1.4 | 1.4.13 |
| `Django` | PyPI | From 1.5 | 1.5.8 |
| `Django` | PyPI | From 1.6 | 1.6.5 |
| `Django` | PyPI | From 1.7a1 | 1.7b4 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Djangoproject Django, Opensuse Opensuse.

## How do I fix CVE-2014-3730?

Upgrade django to a fixed version for your release line: 1.4.13, 1.5.8, 1.6.5 or 1.7b4.

## Is CVE-2014-3730 being exploited?

There is no known exploitation of CVE-2014-3730 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3730 and fix it if it is affected.

What it is: CVE-2014-3730 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 16 May 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-3730 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected from 1.4; fixed in 1.4.13, 1.5.8, 1.6.5, 1.7b4
- django (PyPI): affected from 1.4; fixed in 1.4.13
- django (PyPI): affected from 1.5; fixed in 1.5.8
- django (PyPI): affected from 1.6; fixed in 1.6.5
- django (PyPI): affected from 1.7a1; fixed in 1.7b4
- Django (PyPI): affected from 1.4; fixed in 1.4.13
- Django (PyPI): affected from 1.5; fixed in 1.5.8
- Django (PyPI): affected from 1.6; fixed in 1.6.5
- Django (PyPI): affected from 1.7a1; fixed in 1.7b4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3730/ (Markdown: https://insights.sbomify.com/CVE-2014-3730/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3730
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3730
- OSV: https://osv.dev/vulnerability/CVE-2014-3730

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3730/
Summaries are generated and may contain mistakes; the official description above is the record.
