{"answers":{"affected":"2 open source packages ship an affected version, including printer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-3741 in the wild and no public exploit code.","fix":"Upgrade printer to 0.0.2 or later.","what":"CVE-2014-3741 is a critical command injection vulnerability in n/a, published on 23 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-3741 and fix it if it is affected.\n\nWhat it is: CVE-2014-3741 is a critical command injection vulnerability in n/a, published on 23 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-3741 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- printer (npm): affected all versions; fixed in 0.0.2\n- printer (npm): affected all versions; fixed in 0.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3741/ (Markdown: https://insights.sbomify.com/CVE-2014-3741/index.md)","id":"CVE-2014-3741","markdown":"https://insights.sbomify.com/CVE-2014-3741/index.md","name":"CVE-2014-3741","record":{"aliases":["GHSA-5c8j-xr24-2665"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js printer library","requires_auth":"none","summary":"Remote attackers can execute arbitrary commands via the printDirect function in the node-printer library.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"node-printer","vendor":"node-printer_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"The printDirect function in lib/printer.js in the node-printer module 0.0.1 and earlier for Node.js allows remote attackers to execute arbitrary commands via unspecified characters in the lpr command.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Potential Command Injection in printer","id":"CVE-2014-3741","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2014"},"n_packages":2,"n_references":4,"next":{"headline":"File Descriptor Leak Can Cause DoS Vulnerability in hapi","id":"CVE-2014-3742"},"packages":[{"ecosystem":"npm","fixed":["0.0.2"],"introduced":["0"],"last_affected":[],"package":"printer","purl":null,"source":"GHSA-5c8j-xr24-2665"},{"ecosystem":"npm","fixed":["0.0.2"],"introduced":["0"],"last_affected":[],"package":"printer","purl":"pkg:npm/printer","source":"GHSA-5c8j-xr24-2665"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2014-3740"},"products":["n/a"],"published":"2017-10-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary commands via the printDirect function in the node-printer library.","url":"https://insights.sbomify.com/CVE-2014-3741/"}