{"answers":{"affected":"2 open source packages ship an affected version, including hapi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-3742 in the wild and no public exploit code.","fix":"Upgrade hapi to 2.2.0 or later.","what":"CVE-2014-3742 is a medium-severity vulnerability in n/a, published on 16 May 2014."},"fix_prompt":"Check this codebase for CVE-2014-3742 and fix it if it is affected.\n\nWhat it is: CVE-2014-3742 is a medium-severity vulnerability in n/a, published on 16 May 2014. \nExploitation: There is no known exploitation of CVE-2014-3742 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- hapi (npm): affected from 2.0.0; fixed in 2.2.0\n- hapi (npm): affected from 2.0.0; fixed in 2.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3742/ (Markdown: https://insights.sbomify.com/CVE-2014-3742/index.md)","id":"CVE-2014-3742","markdown":"https://insights.sbomify.com/CVE-2014-3742/index.md","name":"CVE-2014-3742","record":{"aliases":["GHSA-cqr7-78pj-3g7j"],"analysis":null,"analysis_generated_by":null,"assigner":"mitre","cpe":[{"product":"hapi_server_framework","vendor":"spumko_project"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-399","name":null}],"description":"The hapi server framework 2.0.x and 2.1.x before 2.2.0 for Node.js allows remote attackers to cause a denial of service (file descriptor consumption and process crash) via unspecified vectors.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"File Descriptor Leak Can Cause DoS Vulnerability in hapi","id":"CVE-2014-3742","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":null,"year":"2014"},"n_packages":2,"n_references":4,"next":{"headline":"Multiple Content Injection Vulnerabilities in marked","id":"CVE-2014-3743"},"packages":[{"ecosystem":"npm","fixed":["2.2.0"],"introduced":["2.0.0"],"last_affected":[],"package":"hapi","purl":null,"source":"GHSA-cqr7-78pj-3g7j"},{"ecosystem":"npm","fixed":["2.2.0"],"introduced":["2.0.0"],"last_affected":[],"package":"hapi","purl":"pkg:npm/hapi","source":"GHSA-cqr7-78pj-3g7j"}],"prev":{"headline":"Potential Command Injection in printer","id":"CVE-2014-3741"},"products":["n/a"],"published":"2014-05-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2014-3742/"}