# CVE-2014-3744: Directory Traversal in st


- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-69rr-wvh9-6c4q

## What is CVE-2014-3744?

CVE-2014-3744 is a high-severity vulnerability in Nodejs Node.js, published on 23 Oct 2017. 

### Official description

Directory traversal vulnerability in the st module before 0.2.5 for Node.js allows remote attackers to read arbitrary files via a %2e%2e (encoded dot dot) in an unspecified path.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2014-3744?

2 open source packages ship an affected version, including st. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `st` | npm | All versions | 0.2.5 |
| `st` | npm | All versions | 0.2.5 |

Products: Nodejs Node.js.

## How do I fix CVE-2014-3744?

Upgrade st to 0.2.5 or later.

## Is CVE-2014-3744 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-3744 exists.

Public exploit code:

- Node.js st module Directory Traversal (nuclei): http/cves/2014/CVE-2014-3744.yaml

## Other vulnerabilities in Nodejs Node.js

- [CVE-2023-32002](https://insights.sbomify.com/CVE-2023-32002/): Security feature bypass in Node (critical 9.8)
- [CVE-2016-6303](https://insights.sbomify.com/CVE-2016-6303/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-15896](https://insights.sbomify.com/CVE-2017-15896/): Security feature bypass in Node.js (critical 9.1)
- [CVE-2018-7160](https://insights.sbomify.com/CVE-2018-7160/): Server-side request forgery in Node.js (high 8.8)
- [CVE-2018-12120](https://insights.sbomify.com/CVE-2018-12120/): Misconfiguration in Node.js (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3744 and fix it if it is affected.

What it is: CVE-2014-3744 is a high-severity vulnerability in Nodejs Node.js, published on 23 Oct 2017. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-3744 exists.

Affected packages and fixed versions:
- st (npm): affected all versions; fixed in 0.2.5
- st (npm): affected all versions; fixed in 0.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3744/ (Markdown: https://insights.sbomify.com/CVE-2014-3744/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3744
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3744
- OSV: https://osv.dev/vulnerability/CVE-2014-3744

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3744/
Summaries are generated and may contain mistakes; the official description above is the record.
