# CVE-2014-3801: OpenStack Heat template URL information leakage

> Authenticated users can obtain provider template URLs via the resource-type-list in OpenStack Heat, leading to information disclosure.

- **Severity:** Low 3.5 (`AV:N/AC:M/Au:S/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 May 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-3801, GHSA-86qj-4h55-fvpw, PYSEC-2026-889, RHSA-2014:1687, UBUNTU-CVE-2014-3801, USN-2249-1

## What is CVE-2014-3801?

CVE-2014-3801 is a low-severity vulnerability in n/a, published on 23 May 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenStack Orchestration API (Heat) 2013.2 through 2013.2.3 and 2014.1, when creating the stack for a template using a provider template, allows remote authenticated users to obtain the provider template URL via the resource-type-list.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2014-3801?

3 open source packages ship an affected version, including openstack-heat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openstack-heat` | PyPI | All versions | 5.0.0a0 |
| `openstack-heat` | PyPI | All versions | 5.0.0a0 |
| `openstack-heat` | PyPI | All versions | 5.0.0a0 |
| `openstack-heat` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.4-1.el6ost |
| `openstack-heat-api` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.4-1.el6ost |
| `openstack-heat-api-cfn` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.4-1.el6ost |
| `openstack-heat-api-cloudwatch` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.4-1.el6ost |
| `openstack-heat-common` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.4-1.el6ost |
| `openstack-heat-engine` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.4-1.el6ost |

Products: Openstack Heat.

## How do I fix CVE-2014-3801?

Upgrade openstack-heat to 5.0.0a0 or later.

## Is CVE-2014-3801 being exploited?

There is no known exploitation of CVE-2014-3801 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-1625](https://insights.sbomify.com/CVE-2023-1625/): Information leak in api (high 7.4)
- [CVE-2017-2621](https://insights.sbomify.com/CVE-2017-2621/): Information disclosure in openstack-heat (medium 5.9)
- [CVE-2024-7319](https://insights.sbomify.com/CVE-2024-7319/): Openstack-heat: incomplete fix for cve-2023-1625 (medium 5.0)
- [CVE-2016-9185](https://insights.sbomify.com/CVE-2016-9185/): Server-side request forgery in n/a (medium 4.3)
- [CVE-2013-6426](https://insights.sbomify.com/CVE-2013-6426/): Missing authorization in n/a (medium 4.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3801 and fix it if it is affected.

What it is: CVE-2014-3801 is a low-severity vulnerability in n/a, published on 23 May 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3801 in the wild and no public exploit code.

Affected packages and fixed versions:
- openstack-heat (PyPI): affected all versions; fixed in 5.0.0a0
- openstack-heat (PyPI): affected all versions; fixed in 5.0.0a0
- openstack-heat (PyPI): affected all versions; fixed in 5.0.0a0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3801/ (Markdown: https://insights.sbomify.com/CVE-2014-3801/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3801
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3801
- OSV: https://osv.dev/vulnerability/CVE-2014-3801

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3801/
Summaries are generated and may contain mistakes; the official description above is the record.
