CVE-2014-3942 TYPO3 Color Picker Wizard component allows remote authenticated editors to execute arbitrary PHP code

Medium 6.0 Published Updated

Authenticated editors can execute arbitrary PHP code via unsafe deserialization in the Color Picker Wizard component.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-3942?

CVE-2014-3942 is a medium-severity unsafe deserialization vulnerability in Typo3 Typo3, published on 3 Jun 2014. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The Color Picker Wizard component in TYPO3 4.5.0 before 4.5.34, 4.7.0 before 4.7.19, 6.0.0 before 6.0.14, and 6.1.0 before 6.1.9 allows remote authenticated editors to execute arbitrary PHP code via a serialized PHP object.

Weakness: CWE-94

Which versions are affected by CVE-2014-3942?

8 open source packages ship an affected version, including typo3/cms. It affects 1 product.

PackageAffectedFixed in
typo3/cms PackagistFrom 4.5.04.5.34
typo3/cms PackagistFrom 4.5.04.5.34
typo3/cms PackagistFrom 4.7.04.7.19
typo3/cms PackagistFrom 4.7.04.7.19
typo3/cms PackagistFrom 6.0.06.0.14
typo3/cms PackagistFrom 6.0.06.0.14
2 more packages
typo3/cms PackagistFrom 6.1.06.1.9
typo3/cms PackagistFrom 6.1.06.1.9

Products include Typo3 Typo3.

How do I fix CVE-2014-3942?

Upgrade typo3/cms to a fixed version for your release line: 4.5.34, 4.7.19, 6.0.14 or 6.1.9.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2014-3942 being exploited?

There is no known exploitation of CVE-2014-3942 in the wild and no public exploit code.

All Typo3 Typo3 vulnerabilities

Sources

Also known as GHSA-55g3-fjwm-w2c8.

Is CVE-2014-3942 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free