# CVE-2014-3942: TYPO3 Color Picker Wizard component allows remote authenticated editors to execute arbitrary PHP code

> Authenticated editors can execute arbitrary PHP code via unsafe deserialization in the Color Picker Wizard component.

- **Severity:** Medium 6.0 (`AV:N/AC:M/Au:S/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-55g3-fjwm-w2c8

## What is CVE-2014-3942?

CVE-2014-3942 is a medium-severity unsafe deserialization vulnerability in Typo3 Typo3, published on 3 Jun 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Color Picker Wizard component in TYPO3 4.5.0 before 4.5.34, 4.7.0 before 4.7.19, 6.0.0 before 6.0.14, and 6.1.0 before 6.1.9 allows remote authenticated editors to execute arbitrary PHP code via a serialized PHP object.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2014-3942?

8 open source packages ship an affected version, including typo3/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms` | Packagist | From 4.5.0 | 4.5.34 |
| `typo3/cms` | Packagist | From 4.5.0 | 4.5.34 |
| `typo3/cms` | Packagist | From 4.7.0 | 4.7.19 |
| `typo3/cms` | Packagist | From 4.7.0 | 4.7.19 |
| `typo3/cms` | Packagist | From 6.0.0 | 6.0.14 |
| `typo3/cms` | Packagist | From 6.0.0 | 6.0.14 |
| `typo3/cms` | Packagist | From 6.1.0 | 6.1.9 |
| `typo3/cms` | Packagist | From 6.1.0 | 6.1.9 |

Products: Typo3 Typo3.

## How do I fix CVE-2014-3942?

Upgrade typo3/cms to a fixed version for your release line: 4.5.34, 4.7.19, 6.0.14 or 6.1.9.

## Is CVE-2014-3942 being exploited?

There is no known exploitation of CVE-2014-3942 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3942 and fix it if it is affected.

What it is: CVE-2014-3942 is a medium-severity unsafe deserialization vulnerability in Typo3 Typo3, published on 3 Jun 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3942 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms (Packagist): affected from 4.5.0; fixed in 4.5.34
- typo3/cms (Packagist): affected from 4.5.0; fixed in 4.5.34
- typo3/cms (Packagist): affected from 4.7.0; fixed in 4.7.19
- typo3/cms (Packagist): affected from 4.7.0; fixed in 4.7.19
- typo3/cms (Packagist): affected from 6.0.0; fixed in 6.0.14
- typo3/cms (Packagist): affected from 6.0.0; fixed in 6.0.14
- typo3/cms (Packagist): affected from 6.1.0; fixed in 6.1.9
- typo3/cms (Packagist): affected from 6.1.0; fixed in 6.1.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3942/ (Markdown: https://insights.sbomify.com/CVE-2014-3942/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3942
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3942
- OSV: https://osv.dev/vulnerability/CVE-2014-3942

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3942/
Summaries are generated and may contain mistakes; the official description above is the record.
