# CVE-2014-3944: TYPO3 Improper Session Invalidation

> Remote attackers can bypass authentication in TYPO3 by exploiting improper session invalidation, potentially gaining unauthorized access to user accounts.

- **Severity:** Medium 5.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-9j8h-xrgj-7gw2

## What is CVE-2014-3944?

CVE-2014-3944 is a medium-severity authentication bypass vulnerability in Typo3 Typo3, published on 3 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Authentication component in TYPO3 6.2.0 before 6.2.3 does not properly invalidate timed out user sessions, which allows remote attackers to bypass authentication via unspecified vectors.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2014-3944?

2 open source packages ship an affected version, including typo3/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms` | Packagist | From 6.2.0 | 6.2.3 |
| `typo3/cms` | Packagist | From 6.2.0 | 6.2.3 |

Products: Typo3 Typo3.

## How do I fix CVE-2014-3944?

Upgrade typo3/cms to 6.2.3 or later.

## Is CVE-2014-3944 being exploited?

There is no known exploitation of CVE-2014-3944 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3944 and fix it if it is affected.

What it is: CVE-2014-3944 is a medium-severity authentication bypass vulnerability in Typo3 Typo3, published on 3 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3944 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms (Packagist): affected from 6.2.0; fixed in 6.2.3
- typo3/cms (Packagist): affected from 6.2.0; fixed in 6.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3944/ (Markdown: https://insights.sbomify.com/CVE-2014-3944/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3944
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3944
- OSV: https://osv.dev/vulnerability/CVE-2014-3944

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3944/
Summaries are generated and may contain mistakes; the official description above is the record.
