{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-3970 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2014-3970 is a low-severity denial of service vulnerability in n/a, published on 11 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-3970 and fix it if it is affected.\n\nWhat it is: CVE-2014-3970 is a low-severity denial of service vulnerability in n/a, published on 11 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-3970 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3970/ (Markdown: https://insights.sbomify.com/CVE-2014-3970/index.md)","id":"CVE-2014-3970","markdown":"https://insights.sbomify.com/CVE-2014-3970/index.md","name":"CVE-2014-3970","record":{"aliases":["DEBIAN-CVE-2014-3970","GHSA-98qp-j4c5-f834","MGASA-2014-0440","openSUSE-SU-2024:10241-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PulseAudio sound server","requires_auth":"none","summary":"Remote attackers can cause a denial of service in PulseAudio by sending empty UDP packets, triggering an assertion failure and abort.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pulseaudio","vendor":"pulseaudio"}],"cvss":{"score":2.9,"severity":"low","source":"nvd","vector":"AV:A/AC:M/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[],"description":"The pa_rtp_recv function in modules/rtp/rtp.c in the module-rtp-recv module in PulseAudio 5.0 and earlier allows remote attackers to cause a denial of service (assertion failure and abort) via an empty UDP packet.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2014-3970","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2014"},"n_packages":1,"n_references":7,"next":{"headline":"Denial of service in n/a","id":"CVE-2014-3971"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["9.0-2.3"],"introduced":["0"],"last_affected":[],"package":"pulseaudio","purl":"pkg:rpm/opensuse/pulseaudio\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10241-1"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2014-3969"},"products":["n/a"],"published":"2014-06-11","related":[{"cvss_score":7.8,"headline":"Denial of service in n/a","id":"CVE-2007-1804","kev_date_added":null,"published":"2007-04-02"},{"cvss_score":7.2,"headline":"Race condition in n/a","id":"CVE-2009-1894","kev_date_added":null,"published":"2009-07-17"},{"cvss_score":7.2,"headline":"Privilege escalation in n/a","id":"CVE-2008-0008","kev_date_added":null,"published":"2008-01-28"},{"cvss_score":6.9,"headline":"Path traversal in n/a","id":"CVE-2009-1299","kev_date_added":null,"published":"2010-03-18"},{"cvss_score":4,"headline":"Denial of service in Ubuntu's pulseaudio","id":"CVE-2024-11586","kev_date_added":null,"published":"2024-11-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service in PulseAudio by sending empty UDP packets, triggering an assertion failure and abort.","url":"https://insights.sbomify.com/CVE-2014-3970/"}