CVE-2014-3994 Djiblets Cross-site scripting Vulnerability via JSON Objects
Remote attackers can inject arbitrary web script or HTML via JSON objects in Djblets, potentially leading to session hijacking or malicious actions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2014-3994?
CVE-2014-3994 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Jun 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in util/templatetags/djblets_js.py in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django, as used in Review Board, allows remote attackers to inject arbitrary web script or HTML via a JSON object, as demonstrated by the name field when changing a user name.
Weakness: CWE-79
Which versions are affected by CVE-2014-3994?
5 open source packages ship an affected version, including djblets and Djblets. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
djblets PyPI | All versions | 0.7.30, 0.8.3 |
djblets PyPI | All versions | 0.7.30 |
djblets PyPI | From 0.8 | 0.8.3 |
Djblets PyPI | All versions | 0.7.30 |
Djblets PyPI | From 0.8 | 0.8.3 |
Products include Reviewboard Djblets, Reviewboard Reviewboard.
How do I fix CVE-2014-3994?
Upgrade djblets to a fixed version for your release line: 0.7.30 or 0.8.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2014-3994 being exploited?
There is no known exploitation of CVE-2014-3994 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-w7rq-8f2g-jvqr, PYSEC-2014-78.