CVE-2014-3995 Djblets Cross-site scripting Vulnerability
Remote attackers can inject arbitrary web script or HTML via user display names in Djblets, requiring an upgrade to mitigate.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2014-3995?
CVE-2014-3995 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Jun 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in gravatars/templatetags/gravatars.py in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django allows remote attackers to inject arbitrary web script or HTML via a user display name.
Weakness: CWE-79
Which versions are affected by CVE-2014-3995?
5 open source packages ship an affected version, including djblets and Djblets. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
djblets PyPI | All versions | 0.7.30, 0.8.3 |
djblets PyPI | All versions | 0.7.30 |
djblets PyPI | From 0.8 | 0.8.3 |
Djblets PyPI | All versions | 0.7.30 |
Djblets PyPI | From 0.8 | 0.8.3 |
Products include Reviewboard Djblets.
How do I fix CVE-2014-3995?
Upgrade djblets to a fixed version for your release line: 0.7.30 or 0.8.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2014-3995 being exploited?
There is no known exploitation of CVE-2014-3995 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-4xf6-xr96-7vmp, PYSEC-2014-79.