{"answers":{"affected":"5 open source packages ship an affected version, including djblets and Djblets. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-3995 in the wild and no public exploit code.","fix":"Upgrade djblets to a fixed version for your release line: 0.7.30 or 0.8.3.","what":"CVE-2014-3995 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Jun 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-3995 and fix it if it is affected.\n\nWhat it is: CVE-2014-3995 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Jun 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-3995 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- djblets (PyPI): affected all versions; fixed in 0.7.30, 0.8.3\n- djblets (PyPI): affected all versions; fixed in 0.7.30\n- djblets (PyPI): affected from 0.8; fixed in 0.8.3\n- Djblets (PyPI): affected all versions; fixed in 0.7.30\n- Djblets (PyPI): affected from 0.8; fixed in 0.8.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3995/ (Markdown: https://insights.sbomify.com/CVE-2014-3995/index.md)","id":"CVE-2014-3995","markdown":"https://insights.sbomify.com/CVE-2014-3995/index.md","name":"CVE-2014-3995","record":{"aliases":["GHSA-4xf6-xr96-7vmp","PYSEC-2014-79"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Djblets Django library","requires_auth":"low_privilege","summary":"Remote attackers can inject arbitrary web script or HTML via user display names in Djblets, requiring an upgrade to mitigate.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"djblets","vendor":"reviewboard"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in gravatars/templatetags/gravatars.py in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django allows remote attackers to inject arbitrary web script or HTML via a user display name.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Djblets Cross-site scripting Vulnerability","id":"CVE-2014-3995","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2014"},"n_packages":5,"n_references":6,"next":{"headline":"SQL injection in n/a","id":"CVE-2014-3996"},"packages":[{"ecosystem":"PyPI","fixed":["0.7.30"],"introduced":["0"],"last_affected":[],"package":"Djblets","purl":null,"source":"GHSA-4xf6-xr96-7vmp"},{"ecosystem":"PyPI","fixed":["0.8.3"],"introduced":["0.8"],"last_affected":[],"package":"Djblets","purl":null,"source":"GHSA-4xf6-xr96-7vmp"},{"ecosystem":"PyPI","fixed":["0.7.30","0.8.3"],"introduced":["0","0.8"],"last_affected":[],"package":"djblets","purl":"pkg:pypi/djblets","source":"PYSEC-2014-79"},{"ecosystem":"PyPI","fixed":["0.7.30"],"introduced":["0"],"last_affected":[],"package":"djblets","purl":"pkg:pypi/djblets","source":"GHSA-4xf6-xr96-7vmp"},{"ecosystem":"PyPI","fixed":["0.8.3"],"introduced":["0.8"],"last_affected":[],"package":"djblets","purl":"pkg:pypi/djblets","source":"GHSA-4xf6-xr96-7vmp"}],"prev":{"headline":"Djiblets Cross-site scripting Vulnerability via JSON Objects","id":"CVE-2014-3994"},"products":["n/a"],"published":"2014-06-16","related":[{"cvss_score":4.3,"headline":"Djiblets Cross-site scripting Vulnerability via JSON Objects","id":"CVE-2014-3994","kev_date_added":null,"published":"2014-06-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via user display names in Djblets, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2014-3995/"}