# CVE-2014-3995: Djblets Cross-site scripting Vulnerability

> Remote attackers can inject arbitrary web script or HTML via user display names in Djblets, requiring an upgrade to mitigate.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jun 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-4xf6-xr96-7vmp, PYSEC-2014-79

## What is CVE-2014-3995?

CVE-2014-3995 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Jun 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in gravatars/templatetags/gravatars.py in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django allows remote attackers to inject arbitrary web script or HTML via a user display name.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2014-3995?

5 open source packages ship an affected version, including djblets and Djblets. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `djblets` | PyPI | All versions | 0.7.30, 0.8.3 |
| `djblets` | PyPI | All versions | 0.7.30 |
| `djblets` | PyPI | From 0.8 | 0.8.3 |
| `Djblets` | PyPI | All versions | 0.7.30 |
| `Djblets` | PyPI | From 0.8 | 0.8.3 |

Products: Reviewboard Djblets.

## How do I fix CVE-2014-3995?

Upgrade djblets to a fixed version for your release line: 0.7.30 or 0.8.3.

## Is CVE-2014-3995 being exploited?

There is no known exploitation of CVE-2014-3995 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-3994](https://insights.sbomify.com/CVE-2014-3994/): Djiblets Cross-site scripting Vulnerability via JSON Objects (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3995 and fix it if it is affected.

What it is: CVE-2014-3995 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Jun 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-3995 in the wild and no public exploit code.

Affected packages and fixed versions:
- djblets (PyPI): affected all versions; fixed in 0.7.30, 0.8.3
- djblets (PyPI): affected all versions; fixed in 0.7.30
- djblets (PyPI): affected from 0.8; fixed in 0.8.3
- Djblets (PyPI): affected all versions; fixed in 0.7.30
- Djblets (PyPI): affected from 0.8; fixed in 0.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3995/ (Markdown: https://insights.sbomify.com/CVE-2014-3995/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3995
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3995
- OSV: https://osv.dev/vulnerability/CVE-2014-3995

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3995/
Summaries are generated and may contain mistakes; the official description above is the record.
