{"answers":{"affected":"3 open source packages ship an affected version, including ajenti. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-4301 in the wild and no public exploit code.","fix":"Upgrade ajenti to 1.2.21.7 or later.","what":"CVE-2014-4301 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 Jun 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-4301 and fix it if it is affected.\n\nWhat it is: CVE-2014-4301 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 Jun 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-4301 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ajenti (PyPI): affected all versions; fixed in 1.2.21.7\n- ajenti (PyPI): affected all versions; fixed in 1.2.21.7\n- ajenti (PyPI): affected all versions; fixed in 1.2.21.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-4301/ (Markdown: https://insights.sbomify.com/CVE-2014-4301/index.md)","id":"CVE-2014-4301","markdown":"https://insights.sbomify.com/CVE-2014-4301/index.md","name":"CVE-2014-4301","record":{"aliases":["GHSA-2ch8-f849-pjg3","PYSEC-2014-99"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ajenti web panel","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via PATH_INFO in Ajenti, potentially leading to session hijacking or malicious actions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ajenti","vendor":"ajenti"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in the respond_error function in routing.py in Eugene Pankov Ajenti before 1.2.21.7 allow remote attackers to inject arbitrary web script or HTML via the PATH_INFO to (1) resources.js or (2) resources.css in ajenti:static/, related to the traceback page.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Eugene Pankov Ajenti Cross-site scripting Vulnerabilities","id":"CVE-2014-4301","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2014"},"n_packages":3,"n_references":4,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2014-4302"},"packages":[{"ecosystem":"PyPI","fixed":["1.2.21.7"],"introduced":["0"],"last_affected":[],"package":"ajenti","purl":null,"source":"GHSA-2ch8-f849-pjg3"},{"ecosystem":"PyPI","fixed":["1.2.21.7"],"introduced":["0"],"last_affected":[],"package":"ajenti","purl":"pkg:pypi/ajenti","source":"GHSA-2ch8-f849-pjg3"},{"ecosystem":"PyPI","fixed":["1.2.21.7"],"introduced":["0"],"last_affected":[],"package":"ajenti","purl":"pkg:pypi/ajenti","source":"PYSEC-2014-99"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2014-4300"},"products":["n/a"],"published":"2014-06-18","related":[{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2018-1000082","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":8.1,"headline":"Ajenti has a potential Remote Code Execution","id":"CVE-2026-27975","kev_date_added":null,"published":"2026-02-26"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2018-1000081","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":7.5,"headline":"Information disclosure in n/a","id":"CVE-2018-1000126","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":7.2,"headline":"Ajenti has an authorization bypass during custom package installation","id":"CVE-2026-35175","kev_date_added":null,"published":"2026-04-06"},{"cvss_score":6.5,"headline":"Missing authorization in n/a","id":"CVE-2018-1000080","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":6.3,"headline":"ajenti API privileges management","id":"CVE-2019-25066","kev_date_added":null,"published":"2022-06-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via PATH_INFO in Ajenti, potentially leading to session hijacking or malicious actions.","url":"https://insights.sbomify.com/CVE-2014-4301/"}