{"answers":{"affected":"2 open source packages ship an affected version, including logstash. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-4326 in the wild and no public exploit code.","fix":"Upgrade logstash to 1.4.2 or later.","what":"CVE-2014-4326 is a high-severity command injection vulnerability in n/a, published on 22 Jul 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-4326 and fix it if it is affected.\n\nWhat it is: CVE-2014-4326 is a high-severity command injection vulnerability in n/a, published on 22 Jul 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-4326 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- logstash (RubyGems): affected from 1.0.14; fixed in 1.4.2\n- logstash (RubyGems): affected from 1.0.14; fixed in 1.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-4326/ (Markdown: https://insights.sbomify.com/CVE-2014-4326/index.md)","id":"CVE-2014-4326","markdown":"https://insights.sbomify.com/CVE-2014-4326/index.md","name":"CVE-2014-4326","record":{"aliases":["GHSA-8qhq-rq4j-8prj"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Logstash output plugin","requires_auth":"none","summary":"Remote attackers can execute arbitrary commands on Logstash servers via crafted events in Zabbix or Nagios output plugins.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"logstash","vendor":"elastic"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Elasticsearch Logstash 1.0.14 through 1.4.x before 1.4.2 allows remote attackers to execute arbitrary commands via a crafted event in (1) zabbix.rb or (2) nagios_nsca.rb in outputs/.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Elasticsearch Logstash allows remote attackers to execute arbitrary commands","id":"CVE-2014-4326","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"command_injection","year":"2014"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2014-4329"},"packages":[{"ecosystem":"RubyGems","fixed":["1.4.2"],"introduced":["1.0.14"],"last_affected":[],"package":"logstash","purl":null,"source":"GHSA-8qhq-rq4j-8prj"},{"ecosystem":"RubyGems","fixed":["1.4.2"],"introduced":["1.0.14"],"last_affected":[],"package":"logstash","purl":"pkg:gem/logstash","source":"GHSA-8qhq-rq4j-8prj"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2014-4325"},"products":["n/a"],"published":"2014-07-22","related":[{"cvss_score":9.8,"headline":"Information disclosure in Logstash","id":"CVE-2019-7612","kev_date_added":null,"published":"2019-03-25"},{"cvss_score":8.4,"headline":"Logstash Insertion of Sensitive Information into Log File","id":"CVE-2023-46672","kev_date_added":null,"published":"2023-11-15"},{"cvss_score":8.1,"headline":"Improper Limitation of a Pathname to a Restricted Directory in Logstash Leading to Arbitrary File Write","id":"CVE-2026-33466","kev_date_added":null,"published":"2026-04-08"},{"cvss_score":7.5,"headline":"Denial of service in Logstash","id":"CVE-2019-7620","kev_date_added":null,"published":"2019-10-30"},{"cvss_score":7.5,"headline":"Information disclosure in n/a","id":"CVE-2015-5378","kev_date_added":null,"published":"2017-06-27"},{"cvss_score":7.5,"headline":"Logstash Logs Sensitive Information","id":"CVE-2016-1000221","kev_date_added":null,"published":"2017-06-16"},{"cvss_score":7.5,"headline":"Other in n/a","id":"CVE-2016-1000222","kev_date_added":null,"published":"2017-06-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary commands on Logstash servers via crafted events in Zabbix or Nagios output plugins.","url":"https://insights.sbomify.com/CVE-2014-4326/"}