# CVE-2014-4326: Elasticsearch Logstash allows remote attackers to execute arbitrary commands

> Remote attackers can execute arbitrary commands on Logstash servers via crafted events in Zabbix or Nagios output plugins.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jul 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-8qhq-rq4j-8prj

## What is CVE-2014-4326?

CVE-2014-4326 is a high-severity command injection vulnerability in n/a, published on 22 Jul 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Elasticsearch Logstash 1.0.14 through 1.4.x before 1.4.2 allows remote attackers to execute arbitrary commands via a crafted event in (1) zabbix.rb or (2) nagios_nsca.rb in outputs/.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2014-4326?

2 open source packages ship an affected version, including logstash. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `logstash` | RubyGems | From 1.0.14 | 1.4.2 |
| `logstash` | RubyGems | From 1.0.14 | 1.4.2 |

Products: Elastic Logstash.

## How do I fix CVE-2014-4326?

Upgrade logstash to 1.4.2 or later.

## Is CVE-2014-4326 being exploited?

There is no known exploitation of CVE-2014-4326 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-7612](https://insights.sbomify.com/CVE-2019-7612/): Information disclosure in Logstash (critical 9.8)
- [CVE-2023-46672](https://insights.sbomify.com/CVE-2023-46672/): Logstash Insertion of Sensitive Information into Log File (high 8.4)
- [CVE-2026-33466](https://insights.sbomify.com/CVE-2026-33466/): Improper Limitation of a Pathname to a Restricted Directory in Logstash Leading to Arbitrary File Write (high 8.1)
- [CVE-2019-7620](https://insights.sbomify.com/CVE-2019-7620/): Denial of service in Logstash (high 7.5)
- [CVE-2015-5378](https://insights.sbomify.com/CVE-2015-5378/): Information disclosure in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-4326 and fix it if it is affected.

What it is: CVE-2014-4326 is a high-severity command injection vulnerability in n/a, published on 22 Jul 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-4326 in the wild and no public exploit code.

Affected packages and fixed versions:
- logstash (RubyGems): affected from 1.0.14; fixed in 1.4.2
- logstash (RubyGems): affected from 1.0.14; fixed in 1.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-4326/ (Markdown: https://insights.sbomify.com/CVE-2014-4326/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-4326
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-4326
- OSV: https://osv.dev/vulnerability/CVE-2014-4326

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-4326/
Summaries are generated and may contain mistakes; the official description above is the record.
