CVE-2014-4616 simplejson before 2.6.1 vulnerable to array index error
Attackers can read arbitrary process memory via a negative index in the raw_decode function of the Python JSON module.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-4616?
CVE-2014-4616 is a medium-severity vulnerability in Opensuse Opensuse, published on 24 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Array index error in the scanstring function in the _json module in Python 2.7 through 3.5 and simplejson before 2.6.1 allows context-dependent attackers to read arbitrary process memory via a negative index value in the idx argument to the raw_decode function.
Weakness: CWE-129
Which versions are affected by CVE-2014-4616?
3 open source packages ship an affected version, including simplejson. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
simplejson PyPI | All versions | 2.6.1 |
simplejson PyPI | All versions | 2.6.1 |
simplejson PyPI | All versions | 2.6.1 |
Products include Opensuse Opensuse, Opensuse Project Opensuse, Python Python, Simplejson Project Simplejson.
How do I fix CVE-2014-4616?
Upgrade simplejson to 2.6.1 or later.
Is CVE-2014-4616 being exploited?
There is no known exploitation of CVE-2014-4616 in the wild and no public exploit code.
Other vulnerabilities in Opensuse Opensuse
Sources
Also known as ALPINE-CVE-2014-4616, DEBIAN-CVE-2014-4616, GHSA-9772-cwx9-r4cj, MGASA-2014-0286, PSF-2017-1, PYSEC-2026-921 and 1 more.