{"answers":{"affected":"3 open source packages ship an affected version, including simplejson. It affects 4 products.","exploited":"There is no known exploitation of CVE-2014-4616 in the wild and no public exploit code.","fix":"Upgrade simplejson to 2.6.1 or later.","what":"CVE-2014-4616 is a medium-severity vulnerability in Opensuse Opensuse, published on 24 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-4616 and fix it if it is affected.\n\nWhat it is: CVE-2014-4616 is a medium-severity vulnerability in Opensuse Opensuse, published on 24 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-4616 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- simplejson (PyPI): affected all versions; fixed in 2.6.1\n- simplejson (PyPI): affected all versions; fixed in 2.6.1\n- simplejson (PyPI): affected all versions; fixed in 2.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-4616/ (Markdown: https://insights.sbomify.com/CVE-2014-4616/index.md)","id":"CVE-2014-4616","markdown":"https://insights.sbomify.com/CVE-2014-4616/index.md","name":"CVE-2014-4616","record":{"aliases":["ALPINE-CVE-2014-4616","DEBIAN-CVE-2014-4616","GHSA-9772-cwx9-r4cj","MGASA-2014-0286","PSF-2017-1","PYSEC-2026-921","UBUNTU-CVE-2014-4616"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python JSON library","requires_auth":"none","summary":"Attackers can read arbitrary process memory via a negative index in the raw_decode function of the Python JSON module.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"opensuse","vendor":"opensuse"},{"product":"opensuse","vendor":"opensuse_project"},{"product":"python","vendor":"python"},{"product":"simplejson","vendor":"simplejson_project"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-129","name":"Improper Validation of Array Index"}],"description":"Array index error in the scanstring function in the _json module in Python 2.7 through 3.5 and simplejson before 2.6.1 allows context-dependent attackers to read arbitrary process memory via a negative index value in the idx argument to the raw_decode function.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"simplejson before 2.6.1 vulnerable to array index error","id":"CVE-2014-4616","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"opensuse:opensuse","products":["opensuse:opensuse","python:python"],"type":"information_disclosure","year":"2014"},"n_packages":3,"n_references":9,"next":{"headline":"Denial of service in n/a","id":"CVE-2014-4617"},"packages":[{"ecosystem":"PyPI","fixed":["2.6.1"],"introduced":["0"],"last_affected":[],"package":"simplejson","purl":null,"source":"GHSA-9772-cwx9-r4cj"},{"ecosystem":"PyPI","fixed":["2.6.1"],"introduced":["0"],"last_affected":[],"package":"simplejson","purl":"pkg:pypi/simplejson","source":"GHSA-9772-cwx9-r4cj"},{"ecosystem":"PyPI","fixed":["2.6.1"],"introduced":["0"],"last_affected":[],"package":"simplejson","purl":"pkg:pypi/simplejson","source":"PYSEC-2026-921"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2014-4615"},"products":["n/a"],"published":"2017-08-24","related":[{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-5957","kev_date_added":null,"published":"2015-09-28"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-0491","kev_date_added":null,"published":"2015-04-16"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2008-2388","kev_date_added":null,"published":"2008-06-06"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2010-1866","kev_date_added":null,"published":"2010-05-07"},{"cvss_score":9.3,"headline":"Other in n/a","id":"CVE-2015-0492","kev_date_added":null,"published":"2015-04-16"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2014-0158","kev_date_added":null,"published":"2018-04-10"},{"cvss_score":8.8,"headline":"Null dereference in n/a","id":"CVE-2016-4343","kev_date_added":null,"published":"2016-05-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can read arbitrary process memory via a negative index in the raw_decode function of the Python JSON module.","url":"https://insights.sbomify.com/CVE-2014-4616/"}