{"answers":{"affected":"3 open source packages ship an affected version, including ansible. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-4659 in the wild and no public exploit code.","fix":"Upgrade ansible to 1.5.5 or later.","what":"CVE-2014-4659 is a medium-severity vulnerability in n/a, published on 20 Feb 2020. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-4659 and fix it if it is affected.\n\nWhat it is: CVE-2014-4659 is a medium-severity vulnerability in n/a, published on 20 Feb 2020. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-4659 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible (PyPI): affected all versions; fixed in 1.5.5\n- ansible (PyPI): affected all versions; fixed in 1.5.5\n- ansible (PyPI): affected all versions; fixed in 1.5.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-4659/ (Markdown: https://insights.sbomify.com/CVE-2014-4659/index.md)","id":"CVE-2014-4659","markdown":"https://insights.sbomify.com/CVE-2014-4659/index.md","name":"CVE-2014-4659","record":{"aliases":["DEBIAN-CVE-2014-4659","GHSA-6667-f46p-pg88","PYSEC-2020-201"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ansible configuration management","requires_auth":"low_privilege","summary":"Local attackers can read sensitive credentials from Ansible sources.list files due to insecure file permissions.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ansible","vendor":"redhat"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"Ansible before 1.5.5 sets 0644 permissions for sources.list, which might allow local users to obtain sensitive credential information in opportunistic circumstances by reading a file that uses the \"deb http://user:pass@server:port/\" format.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ansible sets unsafe permissions for sources.list","id":"CVE-2014-4659","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2014"},"n_packages":3,"n_references":2,"next":{"headline":"Ansible discloses credential information","id":"CVE-2014-4660"},"packages":[{"ecosystem":"PyPI","fixed":["1.5.5"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-6667-f46p-pg88"},{"ecosystem":"PyPI","fixed":["1.5.5"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-6667-f46p-pg88"},{"ecosystem":"PyPI","fixed":["1.5.5"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"PYSEC-2020-201"}],"prev":{"headline":"Ansible Sensitive Files Are Locally Readable","id":"CVE-2014-4658"},"products":["n/a"],"published":"2020-02-20","related":[{"cvss_score":9.8,"headline":"Ansible Remote Code Execution","id":"CVE-2014-4657","kev_date_added":null,"published":"2020-02-20"},{"cvss_score":9.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4966","kev_date_added":null,"published":"2020-02-18"},{"cvss_score":9.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4967","kev_date_added":null,"published":"2020-02-18"},{"cvss_score":9.8,"headline":"Ansible Insertion of Sensitive Information into Log File vulnerability","id":"CVE-2017-7550","kev_date_added":null,"published":"2017-11-21"},{"cvss_score":8.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-3498","kev_date_added":null,"published":"2017-06-08"},{"cvss_score":8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2017-7466","kev_date_added":null,"published":"2018-06-22"},{"cvss_score":7.8,"headline":"Ansible Sandbox Escape via Symlink Attack","id":"CVE-2015-6240","kev_date_added":null,"published":"2017-06-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local attackers can read sensitive credentials from Ansible sources.list files due to insecure file permissions.","url":"https://insights.sbomify.com/CVE-2014-4659/"}