{"answers":{"affected":"2 open source packages ship an affected version, including hapi. It affects 3 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-4671 exists.","fix":"Upgrade hapi to 6.1.0 or later.","what":"CVE-2014-4671 is a medium-severity vulnerability in Adobe Adobe Air, published on 9 Jul 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-4671 and fix it if it is affected.\n\nWhat it is: CVE-2014-4671 is a medium-severity vulnerability in Adobe Adobe Air, published on 9 Jul 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-4671 exists.\n\nAffected packages and fixed versions:\n- hapi (npm): affected all versions; fixed in 6.1.0\n- hapi (npm): affected all versions; fixed in 6.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-4671/ (Markdown: https://insights.sbomify.com/CVE-2014-4671/index.md)","id":"CVE-2014-4671","markdown":"https://insights.sbomify.com/CVE-2014-4671/index.md","name":"CVE-2014-4671","record":{"aliases":["GHSA-363h-vj6q-3cmj","UBUNTU-CVE-2014-4671","openSUSE-SU-2024:10223-1","openSUSE-SU-2024:11257-1","openSUSE-SU-2024:14155-1","openSUSE-SU-2026:11928-1"],"analysis":{"component_type":"browser","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Adobe Flash Player","requires_auth":"none","summary":"Remote attackers can exploit Adobe Flash Player to perform CSRF attacks against JSONP endpoints, potentially obtaining sensitive information.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"adobe_air","vendor":"adobe"},{"product":"adobe_air_sdk","vendor":"adobe"},{"product":"flash_player","vendor":"adobe"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Adobe Flash Player before 13.0.0.231 and 14.x before 14.0.0.145 on Windows and OS X and before 11.2.202.394 on Linux, Adobe AIR before 14.0.0.137 on Android, Adobe AIR SDK before 14.0.0.137, and Adobe AIR SDK \u0026 Compiler before 14.0.0.137 do not properly restrict the SWF file format, which allows remote attackers to conduct cross-site request forgery (CSRF) attacks against JSONP endpoints, and obtain sensitive information, via a crafted OBJECT element with SWF content satisfying the character-set requirements of a callback API.","ecosystems":["npm","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":"2014-07-08","github_poc":1,"max_poc_stars":0,"metasploit":1,"nuclei":0,"refs":[{"date":"2014-07-08","kind":"metasploit","ref":"auxiliary/gather/flash_rosetta_jsonp_url_disclosure","stars":null,"title":"Flash \"Rosetta\" JSONP GET/POST Response Disclosure"},{"date":"2017-03-21T19:43:46Z","kind":"github_poc","ref":"https://github.com/cph/rabl-old","stars":0,"title":"rabl 0.8.6 + fix for CVE-2014-4671"}],"tier":"weaponised"},"has_fix":true,"headline":"Rosetta-Flash JSONP Vulnerability in hapi","id":"CVE-2014-4671","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"adobe:adobe_air","products":["adobe:adobe_air","adobe:adobe_air_sdk","adobe:flash_player"],"type":"csrf","year":"2014"},"n_packages":4,"n_references":8,"next":{"headline":"Yii PHP Framework arbitrary PHP scripts execution","id":"CVE-2014-4672"},"packages":[{"ecosystem":"npm","fixed":["6.1.0"],"introduced":["0"],"last_affected":[],"package":"hapi","purl":null,"source":"GHSA-363h-vj6q-3cmj"},{"ecosystem":"npm","fixed":["6.1.0"],"introduced":["0"],"last_affected":[],"package":"hapi","purl":"pkg:npm/hapi","source":"GHSA-363h-vj6q-3cmj"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.0.2-1.3"],"introduced":["0"],"last_affected":[],"package":"python-pyramid","purl":"pkg:rpm/opensuse/python-pyramid\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14155-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.1-2.1"],"introduced":["0"],"last_affected":[],"package":"python-pyramid","purl":"pkg:rpm/opensuse/python-pyramid\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11928-1"}],"prev":{"headline":"Use after free in n/a","id":"CVE-2014-4670"},"products":["n/a"],"published":"2014-07-09","related":[{"cvss_score":8.8,"headline":"Adobe Flash Player Double Free Vulnerablity","id":"CVE-2014-0502","kev_date_added":"2024-09-17","published":"2014-02-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2015-0301","kev_date_added":null,"published":"2015-01-13"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-0303","kev_date_added":null,"published":"2015-01-13"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-0304","kev_date_added":null,"published":"2015-01-13"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-0306","kev_date_added":null,"published":"2015-01-13"},{"cvss_score":10,"headline":"Use after free in n/a","id":"CVE-2015-0308","kev_date_added":null,"published":"2015-01-13"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-0309","kev_date_added":null,"published":"2015-01-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can exploit Adobe Flash Player to perform CSRF attacks against JSONP endpoints, potentially obtaining sensitive information.","url":"https://insights.sbomify.com/CVE-2014-4671/"}