# CVE-2014-4671: Rosetta-Flash JSONP Vulnerability in hapi

> Remote attackers can exploit Adobe Flash Player to perform CSRF attacks against JSONP endpoints, potentially obtaining sensitive information.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jul 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-363h-vj6q-3cmj, UBUNTU-CVE-2014-4671, openSUSE-SU-2024:10223-1, openSUSE-SU-2024:11257-1, openSUSE-SU-2024:14155-1, openSUSE-SU-2026:11928-1

## What is CVE-2014-4671?

CVE-2014-4671 is a medium-severity vulnerability in Adobe Adobe Air, published on 9 Jul 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Adobe Flash Player before 13.0.0.231 and 14.x before 14.0.0.145 on Windows and OS X and before 11.2.202.394 on Linux, Adobe AIR before 14.0.0.137 on Android, Adobe AIR SDK before 14.0.0.137, and Adobe AIR SDK & Compiler before 14.0.0.137 do not properly restrict the SWF file format, which allows remote attackers to conduct cross-site request forgery (CSRF) attacks against JSONP endpoints, and obtain sensitive information, via a crafted OBJECT element with SWF content satisfying the character-set requirements of a callback API.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2014-4671?

2 open source packages ship an affected version, including hapi. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hapi` | npm | All versions | 6.1.0 |
| `hapi` | npm | All versions | 6.1.0 |
| `python-pyramid` | openSUSE:Tumbleweed | All versions | 2.0.2-1.3 |
| `python-pyramid` | openSUSE:Tumbleweed | All versions | 2.1-2.1 |

Products: Adobe Adobe Air, Adobe Adobe Air Sdk, Adobe Flash Player.

## How do I fix CVE-2014-4671?

Upgrade hapi to 6.1.0 or later.

## Is CVE-2014-4671 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-4671 exists.

Public exploit code:

- Flash "Rosetta" JSONP GET/POST Response Disclosure (metasploit)
- rabl 0.8.6 + fix for CVE-2014-4671 (github_poc): https://github.com/cph/rabl-old

## Other vulnerabilities in Adobe Adobe Air

- [CVE-2014-0502](https://insights.sbomify.com/CVE-2014-0502/): Adobe Flash Player Double Free Vulnerablity (high 8.8, exploited in the wild)
- [CVE-2015-0301](https://insights.sbomify.com/CVE-2015-0301/): Other in n/a (critical 10.0)
- [CVE-2015-0303](https://insights.sbomify.com/CVE-2015-0303/): Memory corruption in n/a (critical 10.0)
- [CVE-2015-0304](https://insights.sbomify.com/CVE-2015-0304/): Memory corruption in n/a (critical 10.0)
- [CVE-2015-0306](https://insights.sbomify.com/CVE-2015-0306/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-4671 and fix it if it is affected.

What it is: CVE-2014-4671 is a medium-severity vulnerability in Adobe Adobe Air, published on 9 Jul 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-4671 exists.

Affected packages and fixed versions:
- hapi (npm): affected all versions; fixed in 6.1.0
- hapi (npm): affected all versions; fixed in 6.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-4671/ (Markdown: https://insights.sbomify.com/CVE-2014-4671/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-4671
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-4671
- OSV: https://osv.dev/vulnerability/CVE-2014-4671

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-4671/
Summaries are generated and may contain mistakes; the official description above is the record.
