{"answers":{"affected":"2 open source packages ship an affected version, including yiisoft/yii. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-4672 in the wild and no public exploit code.","fix":"Upgrade yiisoft/yii to 1.1.15 or later.","what":"CVE-2014-4672 is a high-severity code injection vulnerability in n/a, published on 3 Jul 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-4672 and fix it if it is affected.\n\nWhat it is: CVE-2014-4672 is a high-severity code injection vulnerability in n/a, published on 3 Jul 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-4672 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yiisoft/yii (Packagist): affected from 1.1.14; fixed in 1.1.15\n- yiisoft/yii (Packagist): affected from 1.1.14; fixed in 1.1.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-4672/ (Markdown: https://insights.sbomify.com/CVE-2014-4672/index.md)","id":"CVE-2014-4672","markdown":"https://insights.sbomify.com/CVE-2014-4672/index.md","name":"CVE-2014-4672","record":{"aliases":["GHSA-74qv-rv53-5wcx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Yii PHP Framework","requires_auth":"none","summary":"Remote attackers can execute arbitrary PHP code via the CDetailView widget in the Yii PHP Framework.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"yiiframework","vendor":"yiiframework"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"The CDetailView widget in Yii PHP Framework 1.1.14 allows remote attackers to execute arbitrary PHP scripts via vectors related to the value property.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Yii PHP Framework arbitrary PHP scripts execution","id":"CVE-2014-4672","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2014"},"n_packages":2,"n_references":1,"next":{"headline":"Command injection in n/a","id":"CVE-2014-4677"},"packages":[{"ecosystem":"Packagist","fixed":["1.1.15"],"introduced":["1.1.14"],"last_affected":[],"package":"yiisoft/yii","purl":null,"source":"GHSA-74qv-rv53-5wcx"},{"ecosystem":"Packagist","fixed":["1.1.15"],"introduced":["1.1.14"],"last_affected":[],"package":"yiisoft/yii","purl":"pkg:composer/yiisoft/yii","source":"GHSA-74qv-rv53-5wcx"}],"prev":{"headline":"Rosetta-Flash JSONP Vulnerability in hapi","id":"CVE-2014-4671"},"products":["n/a"],"published":"2014-07-03","related":[{"cvss_score":8.8,"headline":"Yii Framework Cross-Site Request Forgery (CSRF)","id":"CVE-2018-6009","kev_date_added":null,"published":"2018-01-22"},{"cvss_score":7.5,"headline":"Yii Framework reflected Cross-site Scripting","id":"CVE-2018-6010","kev_date_added":null,"published":"2018-01-22"},{"cvss_score":4.3,"headline":"Yii Framework Cross-site Scripting Vulnerability","id":"CVE-2015-3397","kev_date_added":null,"published":"2015-05-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary PHP code via the CDetailView widget in the Yii PHP Framework.","url":"https://insights.sbomify.com/CVE-2014-4672/"}