# CVE-2014-4672: Yii PHP Framework arbitrary PHP scripts execution

> Remote attackers can execute arbitrary PHP code via the CDetailView widget in the Yii PHP Framework.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-74qv-rv53-5wcx

## What is CVE-2014-4672?

CVE-2014-4672 is a high-severity code injection vulnerability in n/a, published on 3 Jul 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The CDetailView widget in Yii PHP Framework 1.1.14 allows remote attackers to execute arbitrary PHP scripts via vectors related to the value property.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2014-4672?

2 open source packages ship an affected version, including yiisoft/yii. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yiisoft/yii` | Packagist | From 1.1.14 | 1.1.15 |
| `yiisoft/yii` | Packagist | From 1.1.14 | 1.1.15 |

Products: Yiiframework Yiiframework.

## How do I fix CVE-2014-4672?

Upgrade yiisoft/yii to 1.1.15 or later.

## Is CVE-2014-4672 being exploited?

There is no known exploitation of CVE-2014-4672 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-6009](https://insights.sbomify.com/CVE-2018-6009/): Yii Framework Cross-Site Request Forgery (CSRF) (high 8.8)
- [CVE-2018-6010](https://insights.sbomify.com/CVE-2018-6010/): Yii Framework reflected Cross-site Scripting (high 7.5)
- [CVE-2015-3397](https://insights.sbomify.com/CVE-2015-3397/): Yii Framework Cross-site Scripting Vulnerability (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-4672 and fix it if it is affected.

What it is: CVE-2014-4672 is a high-severity code injection vulnerability in n/a, published on 3 Jul 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-4672 in the wild and no public exploit code.

Affected packages and fixed versions:
- yiisoft/yii (Packagist): affected from 1.1.14; fixed in 1.1.15
- yiisoft/yii (Packagist): affected from 1.1.14; fixed in 1.1.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-4672/ (Markdown: https://insights.sbomify.com/CVE-2014-4672/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-4672
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-4672
- OSV: https://osv.dev/vulnerability/CVE-2014-4672

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-4672/
Summaries are generated and may contain mistakes; the official description above is the record.
