# CVE-2014-4678: Ansible Code Injection Vulnerability

> Remote attackers can execute arbitrary code via crafted instructions due to improper restriction in Ansible's safe_eval function.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2020
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-4678, GHSA-66c7-5pwv-mm3j, PYSEC-2020-203, UBUNTU-CVE-2014-4678

## What is CVE-2014-4678?

CVE-2014-4678 is a critical code injection vulnerability in Debian Debian Linux, published on 20 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The safe_eval function in Ansible before 1.6.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-4657.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2014-4678?

3 open source packages ship an affected version, including ansible. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 1.6.4 |
| `ansible` | PyPI | All versions | 1.6.4 |
| `ansible` | PyPI | All versions | 1.6.4 |

Products: Debian Debian Linux, Redhat Ansible.

## How do I fix CVE-2014-4678?

Upgrade ansible to 1.6.4 or later.

## Is CVE-2014-4678 being exploited?

There is no known exploitation of CVE-2014-4678 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-4678 and fix it if it is affected.

What it is: CVE-2014-4678 is a critical code injection vulnerability in Debian Debian Linux, published on 20 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-4678 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 1.6.4
- ansible (PyPI): affected all versions; fixed in 1.6.4
- ansible (PyPI): affected all versions; fixed in 1.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-4678/ (Markdown: https://insights.sbomify.com/CVE-2014-4678/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-4678
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-4678
- OSV: https://osv.dev/vulnerability/CVE-2014-4678

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-4678/
Summaries are generated and may contain mistakes; the official description above is the record.
