{"answers":{"affected":"It affects 4 products.","exploited":"There is no known exploitation of CVE-2014-4909 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2014-4909 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 29 Jul 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-4909 and fix it if it is affected.\n\nWhat it is: CVE-2014-4909 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 29 Jul 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-4909 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-4909/ (Markdown: https://insights.sbomify.com/CVE-2014-4909/index.md)","id":"CVE-2014-4909","markdown":"https://insights.sbomify.com/CVE-2014-4909/index.md","name":"CVE-2014-4909","record":{"aliases":["DEBIAN-CVE-2014-4909","DSA-2988-1","GHSA-g6r7-pq94-29xp","MGASA-2014-0298","UBUNTU-CVE-2014-4909","USN-2279-1","openSUSE-SU-2024:10272-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"BitTorrent client","requires_auth":"none","summary":"Remote attackers can cause denial of service or execute arbitrary code via crafted peer messages due to an integer overflow in Transmission.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"fedora","vendor":"fedoraproject"},{"product":"linux","vendor":"gentoo"},{"product":"transmission","vendor":"transmissionbt"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-189","name":null}],"description":"Integer overflow in the tr_bitfieldEnsureNthBitAlloced function in bitfield.c in Transmission before 2.84 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted peer message, which triggers an out-of-bounds write.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow in n/a","id":"CVE-2014-4909","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","fedoraproject:fedora","gentoo:linux"],"type":"integer_overflow","year":"2014"},"n_packages":1,"n_references":16,"next":{"headline":"Path traversal in n/a","id":"CVE-2014-4910"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.92-3.1"],"introduced":["0"],"last_affected":[],"package":"transmission","purl":"pkg:rpm/opensuse/transmission\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10272-1"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2014-4908"},"products":["n/a"],"published":"2014-07-29","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service or execute arbitrary code via crafted peer messages due to an integer overflow in Transmission.","url":"https://insights.sbomify.com/CVE-2014-4909/"}