{"answers":{"affected":"3 open source packages ship an affected version, including ansible. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-4967 in the wild and no public exploit code.","fix":"Upgrade ansible to 1.6.7 or later.","what":"CVE-2014-4967 is a critical command injection vulnerability in n/a, published on 18 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-4967 and fix it if it is affected.\n\nWhat it is: CVE-2014-4967 is a critical command injection vulnerability in n/a, published on 18 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-4967 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible (PyPI): affected all versions; fixed in 1.6.7\n- ansible (PyPI): affected all versions; fixed in 1.6.7\n- ansible (PyPI): affected all versions; fixed in 1.6.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-4967/ (Markdown: https://insights.sbomify.com/CVE-2014-4967/index.md)","id":"CVE-2014-4967","markdown":"https://insights.sbomify.com/CVE-2014-4967/index.md","name":"CVE-2014-4967","record":{"aliases":["DEBIAN-CVE-2014-4967","GHSA-64cw-m57j-65xj","PYSEC-2020-205","UBUNTU-CVE-2014-4967"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ansible automation tool","requires_auth":"none","summary":"Remote attackers with access to a managed host can execute arbitrary code by injecting arguments into Ansible facts.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ansible","vendor":"redhat"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote attackers to execute arbitrary code by leveraging access to an Ansible managed host and providing a crafted fact, as demonstrated by a fact with (1) a trailing \" src=\" clause, (2) a trailing \" temp=\" clause, or (3) a trailing \" validate=\" clause accompanied by a shell command.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4967","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2014"},"n_packages":3,"n_references":2,"next":{"headline":"Code injection in n/a","id":"CVE-2014-4968"},"packages":[{"ecosystem":"PyPI","fixed":["1.6.7"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-64cw-m57j-65xj"},{"ecosystem":"PyPI","fixed":["1.6.7"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-64cw-m57j-65xj"},{"ecosystem":"PyPI","fixed":["1.6.7"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"PYSEC-2020-205"}],"prev":{"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4966"},"products":["n/a"],"published":"2020-02-18","related":[{"cvss_score":9.8,"headline":"Ansible Remote Code Execution","id":"CVE-2014-4657","kev_date_added":null,"published":"2020-02-20"},{"cvss_score":9.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4966","kev_date_added":null,"published":"2020-02-18"},{"cvss_score":9.8,"headline":"Ansible Insertion of Sensitive Information into Log File vulnerability","id":"CVE-2017-7550","kev_date_added":null,"published":"2017-11-21"},{"cvss_score":8.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-3498","kev_date_added":null,"published":"2017-06-08"},{"cvss_score":8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2017-7466","kev_date_added":null,"published":"2018-06-22"},{"cvss_score":7.8,"headline":"Ansible Sandbox Escape via Symlink Attack","id":"CVE-2015-6240","kev_date_added":null,"published":"2017-06-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers with access to a managed host can execute arbitrary code by injecting arguments into Ansible facts.","url":"https://insights.sbomify.com/CVE-2014-4967/"}