# CVE-2014-4967: Ansible Arbitrary Code Execution

> Remote attackers with access to a managed host can execute arbitrary code by injecting arguments into Ansible facts.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2020
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-4967, GHSA-64cw-m57j-65xj, PYSEC-2020-205, UBUNTU-CVE-2014-4967

## What is CVE-2014-4967?

CVE-2014-4967 is a critical command injection vulnerability in n/a, published on 18 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote attackers to execute arbitrary code by leveraging access to an Ansible managed host and providing a crafted fact, as demonstrated by a fact with (1) a trailing " src=" clause, (2) a trailing " temp=" clause, or (3) a trailing " validate=" clause accompanied by a shell command.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2014-4967?

3 open source packages ship an affected version, including ansible. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 1.6.7 |
| `ansible` | PyPI | All versions | 1.6.7 |
| `ansible` | PyPI | All versions | 1.6.7 |

Products: Redhat Ansible.

## How do I fix CVE-2014-4967?

Upgrade ansible to 1.6.7 or later.

## Is CVE-2014-4967 being exploited?

There is no known exploitation of CVE-2014-4967 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-4657](https://insights.sbomify.com/CVE-2014-4657/): Ansible Remote Code Execution (critical 9.8)
- [CVE-2014-4966](https://insights.sbomify.com/CVE-2014-4966/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2017-7550](https://insights.sbomify.com/CVE-2017-7550/): Ansible Insertion of Sensitive Information into Log File vulnerability (critical 9.8)
- [CVE-2014-3498](https://insights.sbomify.com/CVE-2014-3498/): Ansible Arbitrary Code Execution (high 8.8)
- [CVE-2017-7466](https://insights.sbomify.com/CVE-2017-7466/): Ansible Arbitrary Code Execution (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-4967 and fix it if it is affected.

What it is: CVE-2014-4967 is a critical command injection vulnerability in n/a, published on 18 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-4967 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 1.6.7
- ansible (PyPI): affected all versions; fixed in 1.6.7
- ansible (PyPI): affected all versions; fixed in 1.6.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-4967/ (Markdown: https://insights.sbomify.com/CVE-2014-4967/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-4967
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-4967
- OSV: https://osv.dev/vulnerability/CVE-2014-4967

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-4967/
Summaries are generated and may contain mistakes; the official description above is the record.
