CVE-2014-4986 phpMyAdmin cross-site scripting Vulnerability in Table or Column Names

Low 3.5 Published Updated

Authenticated users can inject scripts via table or column names in phpMyAdmin, potentially compromising other users' sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2014-4986?

CVE-2014-4986 is a low-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 20 Jul 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Multiple cross-site scripting (XSS) vulnerabilities in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.1, 4.1.x before 4.1.14.2, and 4.2.x before 4.2.6 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) table name or (2) column name that is improperly handled during construction of an AJAX confirmation message.

Weakness: CWE-79

Which versions are affected by CVE-2014-4986?

6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.

PackageAffectedFixed in
phpmyadmin/phpmyadmin PackagistFrom 4.0.04.0.10.1
phpmyadmin/phpmyadmin PackagistFrom 4.0.04.0.10.1
phpmyadmin/phpmyadmin PackagistFrom 4.1.04.1.14.2
phpmyadmin/phpmyadmin PackagistFrom 4.1.04.1.14.2
phpmyadmin/phpmyadmin PackagistFrom 4.2.04.2.6
phpmyadmin/phpmyadmin PackagistFrom 4.2.04.2.6

Products include Phpmyadmin Phpmyadmin.

How do I fix CVE-2014-4986?

Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.1, 4.1.14.2 or 4.2.6.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2014-4986 being exploited?

There is no known exploitation of CVE-2014-4986 in the wild and no public exploit code.

All Phpmyadmin Phpmyadmin vulnerabilities

Sources

Also known as DEBIAN-CVE-2014-4986, GHSA-jqmr-wqgp-8mh2, UBUNTU-CVE-2014-4986.

Is CVE-2014-4986 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free