{"answers":{"affected":"6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-4986 in the wild and no public exploit code.","fix":"Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.1, 4.1.14.2 or 4.2.6.","what":"CVE-2014-4986 is a low-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 20 Jul 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-4986 and fix it if it is affected.\n\nWhat it is: CVE-2014-4986 is a low-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 20 Jul 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-4986 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.0.0; fixed in 4.0.10.1\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.0.0; fixed in 4.0.10.1\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.1.0; fixed in 4.1.14.2\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.1.0; fixed in 4.1.14.2\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.2.0; fixed in 4.2.6\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.2.0; fixed in 4.2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-4986/ (Markdown: https://insights.sbomify.com/CVE-2014-4986/index.md)","id":"CVE-2014-4986","markdown":"https://insights.sbomify.com/CVE-2014-4986/index.md","name":"CVE-2014-4986","record":{"aliases":["DEBIAN-CVE-2014-4986","GHSA-jqmr-wqgp-8mh2","UBUNTU-CVE-2014-4986"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Database management tool","requires_auth":"low_privilege","summary":"Authenticated users can inject scripts via table or column names in phpMyAdmin, potentially compromising other users' sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":3.5,"severity":"low","source":"nvd","vector":"AV:N/AC:M/Au:S/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.1, 4.1.x before 4.1.14.2, and 4.2.x before 4.2.6 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) table name or (2) column name that is improperly handled during construction of an AJAX confirmation message.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpMyAdmin cross-site scripting Vulnerability in Table or Column Names","id":"CVE-2014-4986","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyadmin:phpmyadmin","products":["phpmyadmin:phpmyadmin"],"type":"xss","year":"2014"},"n_packages":6,"n_references":6,"next":{"headline":"Missing authorization in n/a","id":"CVE-2014-4987"},"packages":[{"ecosystem":"Packagist","fixed":["4.0.10.1"],"introduced":["4.0.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-jqmr-wqgp-8mh2"},{"ecosystem":"Packagist","fixed":["4.0.10.1"],"introduced":["4.0.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-jqmr-wqgp-8mh2"},{"ecosystem":"Packagist","fixed":["4.1.14.2"],"introduced":["4.1.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-jqmr-wqgp-8mh2"},{"ecosystem":"Packagist","fixed":["4.1.14.2"],"introduced":["4.1.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-jqmr-wqgp-8mh2"},{"ecosystem":"Packagist","fixed":["4.2.6"],"introduced":["4.2.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-jqmr-wqgp-8mh2"},{"ecosystem":"Packagist","fixed":["4.2.6"],"introduced":["4.2.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-jqmr-wqgp-8mh2"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2014-4984"},"products":["n/a"],"published":"2014-07-20","related":[{"cvss_score":10,"headline":"Misconfiguration in n/a","id":"CVE-2008-7251","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"phpMyAdmin unsafely handles temporary files","id":"CVE-2008-7252","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2007-0203","kev_date_added":null,"published":"2007-01-11"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2004-1147","kev_date_added":null,"published":"2004-12-15"},{"cvss_score":9.8,"headline":"phpmyadmin contains SQL Injection vulnerability","id":"CVE-2020-22452","kev_date_added":null,"published":"2023-01-26"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-11768","kev_date_added":null,"published":"2019-06-05"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-6798","kev_date_added":null,"published":"2019-01-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Authenticated users can inject scripts via table or column names in phpMyAdmin, potentially compromising other users' sessions.","url":"https://insights.sbomify.com/CVE-2014-4986/"}