# CVE-2014-4994: Gyazo allows local users to write arbitrary files

> Local attackers can overwrite arbitrary files via symlink attacks on temporary files in the gyazo Ruby gem.

- **Severity:** Medium 5.5 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jan 2018
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-6x45-86q6-rcmr

## What is CVE-2014-4994?

CVE-2014-4994 is a medium-severity path traversal vulnerability in n/a, published on 10 Jan 2018. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

lib/gyazo/client.rb in the gyazo gem 1.0.0 for Ruby allows local users to write to arbitrary files via a symlink attack on a temporary file, related to time-based filenames.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2014-4994?

2 open source packages ship an affected version, including gyazo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gyazo` | RubyGems | From 1.0.0 | 2.0.0 |
| `gyazo` | RubyGems | From 1.0.0 | 2.0.0 |

Products: Gyazo Project Gyazo.

## How do I fix CVE-2014-4994?

Upgrade gyazo to 2.0.0 or later.

## Is CVE-2014-4994 being exploited?

There is no known exploitation of CVE-2014-4994 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-4994 and fix it if it is affected.

What it is: CVE-2014-4994 is a medium-severity path traversal vulnerability in n/a, published on 10 Jan 2018. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-4994 in the wild and no public exploit code.

Affected packages and fixed versions:
- gyazo (RubyGems): affected from 1.0.0; fixed in 2.0.0
- gyazo (RubyGems): affected from 1.0.0; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-4994/ (Markdown: https://insights.sbomify.com/CVE-2014-4994/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-4994
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-4994
- OSV: https://osv.dev/vulnerability/CVE-2014-4994

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-4994/
Summaries are generated and may contain mistakes; the official description above is the record.
