{"answers":{"affected":"2 open source packages ship an affected version, including lynx. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-5002 in the wild and no public exploit code.","fix":"Upgrade lynx to 1.0.0 or later.","what":"CVE-2014-5002 is a high-severity vulnerability in n/a, published on 10 Jan 2018. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-5002 and fix it if it is affected.\n\nWhat it is: CVE-2014-5002 is a high-severity vulnerability in n/a, published on 10 Jan 2018. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-5002 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- lynx (RubyGems): affected all versions; fixed in 1.0.0\n- lynx (RubyGems): affected all versions; fixed in 1.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-5002/ (Markdown: https://insights.sbomify.com/CVE-2014-5002/index.md)","id":"CVE-2014-5002","markdown":"https://insights.sbomify.com/CVE-2014-5002/index.md","name":"CVE-2014-5002","record":{"aliases":["GHSA-94cq-7ccq-cmcm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ruby lynx gem","requires_auth":"low_privilege","summary":"Local attackers can read sensitive passwords from process listings due to insecure command-line handling in the lynx Ruby gem.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"lynx","vendor":"lynx_project"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-255","name":null}],"description":"The lynx gem before 1.0.0 for Ruby places the configured password on command lines, which allows local users to obtain sensitive information by listing processes.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"lynx doesn't properly sanitize user input and exposes database password to unauthorized users","id":"CVE-2014-5002","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"information_disclosure","year":"2014"},"n_packages":2,"n_references":4,"next":{"headline":"Ciborg gem for Ruby allows local users to write files and gain privileges via Symlink","id":"CVE-2014-5003"},"packages":[{"ecosystem":"RubyGems","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"lynx","purl":null,"source":"GHSA-94cq-7ccq-cmcm"},{"ecosystem":"RubyGems","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"lynx","purl":"pkg:gem/lynx","source":"GHSA-94cq-7ccq-cmcm"}],"prev":{"headline":"Kcapifony gem for Ruby places database user passwords on the command line","id":"CVE-2014-5001"},"products":["n/a"],"published":"2018-01-10","related":[{"cvss_score":7.8,"headline":"Command injection in n/a","id":"CVE-1999-1549","kev_date_added":null,"published":"2001-09-12"},{"cvss_score":5.3,"headline":"Use after free in n/a","id":"CVE-2017-1000211","kev_date_added":null,"published":"2017-11-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local attackers can read sensitive passwords from process listings due to insecure command-line handling in the lynx Ruby gem.","url":"https://insights.sbomify.com/CVE-2014-5002/"}