# CVE-2014-5002: lynx doesn't properly sanitize user input and exposes database password to unauthorized users

> Local attackers can read sensitive passwords from process listings due to insecure command-line handling in the lynx Ruby gem.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jan 2018
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-94cq-7ccq-cmcm

## What is CVE-2014-5002?

CVE-2014-5002 is a high-severity vulnerability in n/a, published on 10 Jan 2018. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The lynx gem before 1.0.0 for Ruby places the configured password on command lines, which allows local users to obtain sensitive information by listing processes.

Weakness: CWE-255

## Which versions are affected by CVE-2014-5002?

2 open source packages ship an affected version, including lynx. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lynx` | RubyGems | All versions | 1.0.0 |
| `lynx` | RubyGems | All versions | 1.0.0 |

Products: Lynx Project Lynx.

## How do I fix CVE-2014-5002?

Upgrade lynx to 1.0.0 or later.

## Is CVE-2014-5002 being exploited?

There is no known exploitation of CVE-2014-5002 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-1999-1549](https://insights.sbomify.com/CVE-1999-1549/): Command injection in n/a (high 7.8)
- [CVE-2017-1000211](https://insights.sbomify.com/CVE-2017-1000211/): Use after free in n/a (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-5002 and fix it if it is affected.

What it is: CVE-2014-5002 is a high-severity vulnerability in n/a, published on 10 Jan 2018. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-5002 in the wild and no public exploit code.

Affected packages and fixed versions:
- lynx (RubyGems): affected all versions; fixed in 1.0.0
- lynx (RubyGems): affected all versions; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-5002/ (Markdown: https://insights.sbomify.com/CVE-2014-5002/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-5002
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-5002
- OSV: https://osv.dev/vulnerability/CVE-2014-5002

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-5002/
Summaries are generated and may contain mistakes; the official description above is the record.
