CVE-2014-5012 DOMPDF denial of service vulnerability
Medium 6.5
Published
Updated
Check this codebase for CVE-2014-5012 and fix it if it is affected.
What it is: CVE-2014-5012 is a medium-severity vulnerability in n/a, published on 10 Jan 2020.
Exploitation: There is no known exploitation of CVE-2014-5012 in the wild and no public exploit code.
Affected packages and fixed versions:
- dompdf/dompdf (Packagist): affected from 0.6; fixed in 0.6.2
- dompdf/dompdf (Packagist): affected from 0.6; fixed in 0.6.2
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2014-5012/ (Markdown: https://insights.sbomify.com/CVE-2014-5012/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2014-5012?
CVE-2014-5012 is a medium-severity vulnerability in n/a, published on 10 Jan 2020.
Official description
DOMPDF before 0.6.2 allows denial of service.
Which versions are affected by CVE-2014-5012?
2 open source packages ship an affected version, including dompdf/dompdf. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
dompdf/dompdf Packagist | From 0.6 | 0.6.2 |
dompdf/dompdf Packagist | From 0.6 | 0.6.2 |
Products include Dompdf Project Dompdf.
How do I fix CVE-2014-5012?
Upgrade dompdf/dompdf to 0.6.2 or later.
Is CVE-2014-5012 being exploited?
There is no known exploitation of CVE-2014-5012 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2023-24813 URI validation failure on SVG parsing. Bypass of CVE-2023-23924
- CVE-2023-23924 URI validation failure on SVG parsing in Dompdf
- CVE-2021-3838 PHAR Deserialization in dompdf/dompdf
- CVE-2021-3902 Improper Restriction of XML External Entity Reference in dompdf/dompdf
- CVE-2022-28368 Remote code injection in dompdf/dompdf
Sources
Also known as DEBIAN-CVE-2014-5012, GHSA-q83c-64c9-c42m, UBUNTU-CVE-2014-5012.