# CVE-2014-5012: DOMPDF denial of service vulnerability


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 10 Jan 2020
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-5012, GHSA-q83c-64c9-c42m, UBUNTU-CVE-2014-5012

## What is CVE-2014-5012?

CVE-2014-5012 is a medium-severity vulnerability in n/a, published on 10 Jan 2020. 

### Official description

DOMPDF before 0.6.2 allows denial of service.

## Which versions are affected by CVE-2014-5012?

2 open source packages ship an affected version, including dompdf/dompdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dompdf/dompdf` | Packagist | From 0.6 | 0.6.2 |
| `dompdf/dompdf` | Packagist | From 0.6 | 0.6.2 |

Products: Dompdf Project Dompdf.

## How do I fix CVE-2014-5012?

Upgrade dompdf/dompdf to 0.6.2 or later.

## Is CVE-2014-5012 being exploited?

There is no known exploitation of CVE-2014-5012 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-24813](https://insights.sbomify.com/CVE-2023-24813/): URI validation failure on SVG parsing. Bypass of CVE-2023-23924 (critical 10.0)
- [CVE-2023-23924](https://insights.sbomify.com/CVE-2023-23924/): URI validation failure on SVG parsing in Dompdf (critical 10.0)
- [CVE-2021-3838](https://insights.sbomify.com/CVE-2021-3838/): PHAR Deserialization in dompdf/dompdf (critical 9.8)
- [CVE-2021-3902](https://insights.sbomify.com/CVE-2021-3902/): Improper Restriction of XML External Entity Reference in dompdf/dompdf (critical 9.8)
- [CVE-2022-28368](https://insights.sbomify.com/CVE-2022-28368/): Remote code injection in dompdf/dompdf (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-5012 and fix it if it is affected.

What it is: CVE-2014-5012 is a medium-severity vulnerability in n/a, published on 10 Jan 2020. 
Exploitation: There is no known exploitation of CVE-2014-5012 in the wild and no public exploit code.

Affected packages and fixed versions:
- dompdf/dompdf (Packagist): affected from 0.6; fixed in 0.6.2
- dompdf/dompdf (Packagist): affected from 0.6; fixed in 0.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-5012/ (Markdown: https://insights.sbomify.com/CVE-2014-5012/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-5012
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-5012
- OSV: https://osv.dev/vulnerability/CVE-2014-5012

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-5012/
Summaries are generated and may contain mistakes; the official description above is the record.
