CVE-2014-5028 Information disclosure in n/a
Authenticated users can bypass access restrictions to view sensitive repository file contents by guessing database IDs.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2014-5028?
CVE-2014-5028 is a medium-severity vulnerability in n/a, published on 29 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The Original File and Patched File resources in Review Board 1.7.x before 1.7.27 and 2.0.x before 2.0.4 allow remote authenticated users to bypass intended access restrictions and obtain sensitive information from repository files by leveraging knowledge of database ids.
Weakness: CWE-200
Which versions are affected by CVE-2014-5028?
It affects 1 product.
Products include Reviewboard Review Board.
How do I fix CVE-2014-5028?
No fix has been published for CVE-2014-5028 yet. Limit exposure of the affected software until one is available.
Is CVE-2014-5028 being exploited?
There is no known exploitation of CVE-2014-5028 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-p869-r3h5-mpvv.