{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2014-5118 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2014-5118 is a medium-severity vulnerability in Fedoraproject Fedora, published on 18 Nov 2019. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-5118 and fix it if it is affected.\n\nWhat it is: CVE-2014-5118 is a medium-severity vulnerability in Fedoraproject Fedora, published on 18 Nov 2019. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-5118 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-5118/ (Markdown: https://insights.sbomify.com/CVE-2014-5118/index.md)","id":"CVE-2014-5118","markdown":"https://insights.sbomify.com/CVE-2014-5118/index.md","name":"CVE-2014-5118","record":{"aliases":["GHSA-fcqp-4gp4-9mfg","RHBA-2015:0584","SUSE-SU-2017:3114-1"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Trusted Boot","requires_auth":"low_privilege","summary":"Attackers can bypass security checks in Trusted Boot, potentially compromising system integrity during the boot process.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"enterprise_linux","vendor":"redhat"},{"product":"trusted_boot","vendor":"trusted_boot_project"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Trusted Boot (tboot) before 1.8.2 has a 'loader.c' Security Bypass Vulnerability","ecosystems":["Red Hat:enterprise_linux:7::client","Red Hat:enterprise_linux:7::computenode","Red Hat:enterprise_linux:7::server","Red Hat:enterprise_linux:7::workstation","SUSE:Linux Enterprise Server 11 SP4","SUSE:Linux Enterprise Server for SAP Applications 11 SP4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security feature bypass in n/a","id":"CVE-2014-5118","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora","redhat:enterprise_linux"],"type":"security_feature_bypass","year":"2014"},"n_packages":10,"n_references":5,"next":{"headline":"Integer overflow in n/a","id":"CVE-2014-5119"},"packages":[{"ecosystem":"Red Hat:enterprise_linux:7::client","fixed":["1:1.8.2-1.el7"],"introduced":["0"],"last_affected":[],"package":"tboot","purl":"pkg:rpm/redhat/tboot","source":"RHBA-2015:0584"},{"ecosystem":"Red Hat:enterprise_linux:7::client","fixed":["1:1.8.2-1.el7"],"introduced":["0"],"last_affected":[],"package":"tboot-debuginfo","purl":"pkg:rpm/redhat/tboot-debuginfo","source":"RHBA-2015:0584"},{"ecosystem":"Red Hat:enterprise_linux:7::computenode","fixed":["1:1.8.2-1.el7"],"introduced":["0"],"last_affected":[],"package":"tboot","purl":"pkg:rpm/redhat/tboot","source":"RHBA-2015:0584"},{"ecosystem":"Red Hat:enterprise_linux:7::computenode","fixed":["1:1.8.2-1.el7"],"introduced":["0"],"last_affected":[],"package":"tboot-debuginfo","purl":"pkg:rpm/redhat/tboot-debuginfo","source":"RHBA-2015:0584"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["1:1.8.2-1.el7"],"introduced":["0"],"last_affected":[],"package":"tboot","purl":"pkg:rpm/redhat/tboot","source":"RHBA-2015:0584"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["1:1.8.2-1.el7"],"introduced":["0"],"last_affected":[],"package":"tboot-debuginfo","purl":"pkg:rpm/redhat/tboot-debuginfo","source":"RHBA-2015:0584"},{"ecosystem":"Red Hat:enterprise_linux:7::workstation","fixed":["1:1.8.2-1.el7"],"introduced":["0"],"last_affected":[],"package":"tboot","purl":"pkg:rpm/redhat/tboot","source":"RHBA-2015:0584"},{"ecosystem":"Red Hat:enterprise_linux:7::workstation","fixed":["1:1.8.2-1.el7"],"introduced":["0"],"last_affected":[],"package":"tboot-debuginfo","purl":"pkg:rpm/redhat/tboot-debuginfo","source":"RHBA-2015:0584"},{"ecosystem":"SUSE:Linux Enterprise Server 11 SP4","fixed":["20120115_1.7.0-0.5.5.1"],"introduced":["0"],"last_affected":[],"package":"tboot","purl":"pkg:rpm/suse/tboot\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP4","source":"SUSE-SU-2017:3114-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 11 SP4","fixed":["20120115_1.7.0-0.5.5.1"],"introduced":["0"],"last_affected":[],"package":"tboot","purl":"pkg:rpm/suse/tboot\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2011%20SP4","source":"SUSE-SU-2017:3114-1"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2014-5117"},"products":["n/a"],"published":"2019-11-18","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHBA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can bypass security checks in Trusted Boot, potentially compromising system integrity during the boot process.","url":"https://insights.sbomify.com/CVE-2014-5118/"}