{"answers":{"affected":"2 open source packages ship an affected version, including ckeditor/ckeditor. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-5191 in the wild and no public exploit code.","fix":"Upgrade ckeditor/ckeditor to 4.4.3 or later.","what":"CVE-2014-5191 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Aug 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-5191 and fix it if it is affected.\n\nWhat it is: CVE-2014-5191 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Aug 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-5191 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ckeditor/ckeditor (Packagist): affected all versions; fixed in 4.4.3\n- ckeditor/ckeditor (Packagist): affected all versions; fixed in 4.4.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-5191/ (Markdown: https://insights.sbomify.com/CVE-2014-5191/index.md)","id":"CVE-2014-5191","markdown":"https://insights.sbomify.com/CVE-2014-5191/index.md","name":"CVE-2014-5191","record":{"aliases":["DEBIAN-CVE-2014-5191","GHSA-v27h-j97p-wqmx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"CKEditor Preview plugin","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via the CKEditor Preview plugin, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ckeditor","vendor":"ckeditor"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the Preview plugin before 4.4.3 in CKEditor allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"The Preview plugin in CKEditor allows Cross-site scripting (XSS)","id":"CVE-2014-5191","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2014"},"n_packages":2,"n_references":3,"next":{"headline":"SQL injection in n/a","id":"CVE-2014-5192"},"packages":[{"ecosystem":"Packagist","fixed":["4.4.3"],"introduced":["0"],"last_affected":[],"package":"ckeditor/ckeditor","purl":null,"source":"GHSA-v27h-j97p-wqmx"},{"ecosystem":"Packagist","fixed":["4.4.3"],"introduced":["0"],"last_affected":[],"package":"ckeditor/ckeditor","purl":"pkg:composer/ckeditor/ckeditor","source":"GHSA-v27h-j97p-wqmx"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2014-5190"},"products":["n/a"],"published":"2014-08-07","related":[{"cvss_score":9.8,"headline":"File upload in n/a","id":"CVE-2023-31541","kev_date_added":null,"published":"2023-06-13"},{"cvss_score":8.2,"headline":"Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML","id":"CVE-2021-41164","kev_date_added":null,"published":"2021-11-17"},{"cvss_score":8.2,"headline":"HTML comments vulnerability allowing to execute JavaScript code","id":"CVE-2021-41165","kev_date_added":null,"published":"2021-11-17"},{"cvss_score":7.6,"headline":"Cross-site scripting in ckeditor via abuse of undo functionality","id":"CVE-2021-32808","kev_date_added":null,"published":"2021-08-12"},{"cvss_score":7.5,"headline":"Missing authorization in CKEditor Drupal module","id":"CVE-2011-4972","kev_date_added":null,"published":"2019-11-13"},{"cvss_score":7.3,"headline":"Execution of JavaScript code using malformed HTML in ckeditor","id":"CVE-2021-37695","kev_date_added":null,"published":"2021-08-12"},{"cvss_score":6.8,"headline":"Code injection in n/a","id":"CVE-2012-2067","kev_date_added":null,"published":"2012-09-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via the CKEditor Preview plugin, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2014-5191/"}