# CVE-2014-5191: The Preview plugin in CKEditor allows Cross-site scripting (XSS)

> Remote attackers can inject arbitrary web script or HTML via the CKEditor Preview plugin, potentially compromising user sessions.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Aug 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-5191, GHSA-v27h-j97p-wqmx

## What is CVE-2014-5191?

CVE-2014-5191 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Aug 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the Preview plugin before 4.4.3 in CKEditor allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2014-5191?

2 open source packages ship an affected version, including ckeditor/ckeditor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ckeditor/ckeditor` | Packagist | All versions | 4.4.3 |
| `ckeditor/ckeditor` | Packagist | All versions | 4.4.3 |

Products: Ckeditor Ckeditor.

## How do I fix CVE-2014-5191?

Upgrade ckeditor/ckeditor to 4.4.3 or later.

## Is CVE-2014-5191 being exploited?

There is no known exploitation of CVE-2014-5191 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-31541](https://insights.sbomify.com/CVE-2023-31541/): File upload in n/a (critical 9.8)
- [CVE-2021-41164](https://insights.sbomify.com/CVE-2021-41164/): Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML (high 8.2)
- [CVE-2021-41165](https://insights.sbomify.com/CVE-2021-41165/): HTML comments vulnerability allowing to execute JavaScript code (high 8.2)
- [CVE-2021-32808](https://insights.sbomify.com/CVE-2021-32808/): Cross-site scripting in ckeditor via abuse of undo functionality (high 7.6)
- [CVE-2011-4972](https://insights.sbomify.com/CVE-2011-4972/): Missing authorization in CKEditor Drupal module (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-5191 and fix it if it is affected.

What it is: CVE-2014-5191 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Aug 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-5191 in the wild and no public exploit code.

Affected packages and fixed versions:
- ckeditor/ckeditor (Packagist): affected all versions; fixed in 4.4.3
- ckeditor/ckeditor (Packagist): affected all versions; fixed in 4.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-5191/ (Markdown: https://insights.sbomify.com/CVE-2014-5191/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-5191
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-5191
- OSV: https://osv.dev/vulnerability/CVE-2014-5191

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-5191/
Summaries are generated and may contain mistakes; the official description above is the record.
